[Question] EndeavourOS Welcome Greeter

Not really bugs, just curious.

Sometime during the recent updates the “Don’t show me anymore” button has disappeared from the Welcome Greeter. Is that by design or oversight?

Also over the last week there have been almost daily updates to the Greeter/Welcome script. Are those real updates or is the version number being changed by some automated script?

1 Like

That’s by design. “Don’t show me anymore” was a bit confusing to many people, so it was decided to be removed. Note that there’s another way to stop seeing the welcome app, by disabling it in the Application Autostart.

And the frequent updates were a result of development of more features, including fixing a small but pesky bug.

3 Likes

@manuel thanks for the update. I was just being nosey.

No problem! I was actually waiting for someone to ask why so many updates… :wink:

2 Likes

I have to plead guilty here. It is because of a bug I reported - and which is finally fixed, thanks @manuel - that the Welcome package has been so modified…

3 Likes

Great that you reported the bug. Otherwise it would have left unnoticed for now, and caused annoyance to some users.

Reporting bugs is a really useful way for having improvements for us all.

1 Like

You know, I’m Bugman after all. And I found another weird bug if you’re using Mate with Seahorse. It breaks logout / reboot / shutdown process with Gnome-keyring 3.34.0. A downgrade is needed. See this bug report: https://bugs.archlinux.org/task/63995

Using EndeavourOS in a virtualmachine helped me nailing the bug.

1 Like

I didn’t know what seahorse was until i looked. :wink:

Well, it is a useful tool for me. It helps me managing keyring on my Mate-desktop installation. Too bad gnome-keyring 3.34 seems to be broken :frowning:

Hello gents!
Just finished my EndeavourOS install with Plasma, everything works.
But I just can’t disable the EndeavourOS Welcome greeter, and it doesn’t shows up in the setings/autostart.
Suggestions?

Thanks for reporting!

It is possible to disable it by editing file /etc/xdg/autostart/welcome.desktop and setting value:

    Hidden=true

In fact we recently removed the button “Don’t show me anymore” from the Welcome app.
We could put it back for DEs that do not work well with autostart. I hope it can be done this week.

1 Like

I have plasma installed in vbox on Uefi so i will check it on mine.

Edit: Also don’t see anyway of turning off autostart. It’s not listed there.

With welcome version 1.9-1 you should be able to disable the welcome app with a button named “Don’t show me anymore” in the app itself.

This button is visible only in KDE since KDE doesn’t seem to play well with Autostart.

1 Like

My solution was: sudo pacman -R welcome
But that is a drastic solution. :stuck_out_tongue:

2 Likes