Question about i2c driver

I just installed OpenRGB but it asks me to load the i2c driver. I searched infos both on the internet site of the linux kernel than around the net but I can’t find what I have to digit in terminal for make it works.
Then, being a low level piece of software, I’m asking if it is unloaded by default for security reasons.
Is there anyone that could explain this?
Thanks in advance.

I think you would need to post the output that shows what it is doing and asking for. i2c should already be in the kernel but maybe it’s not loading for OpenRGB and you need to make some change. Maybe post the output so we can see what it is showing. Post all of it not just the one line.

I think you just have to:

echo i2c-dev >> /etc/modules-load.d/i2c-dev.conf

in order to permanently load the I²C module (after a reboot).

You might also have to install i2c-tools.

1 Like

I think you are right.

There’s no i2c-dev.conf in /etc/modules-load.d
So, Maybe I have to install the module. Being a beginner, what I have to use for installing it? Dkms?

The command that was given tells it to write 12c-dev in /etc/modules-load.d/12c-dev.conf file which doesn’t exist until it is created by the command.

Edit: The i2c-dev module is part of the kernel. The command is creating a .conf file to tell it to load that module when you boot the kernel.

I gave the command but it doesn’t create anything inside modules-load.d… the folder is still empty.


echo 'i2c-dev' | sudo tee -a /etc/modules-load.d/i2c-dev.conf
should work! I guess you are having a permission issue.

The command still does the same thing as before, only in another way:

1 Like

Now the file has been created but OpenRGB still raises the screen with the message…


By the way, I use AMD cpu…

Did you reboot afterwards?
And is i2c-tools installed?

yes I did

I mean after reading your error message…
you might have to load another module.
echo 'i2c-piix4' | sudo tee -a /etc/modules-load.d/i2c-piix4.conf

I am out of ideas. As far as I remember loading i2c-dev was enough on my system.

Rescanning on OpenRGB shows the same screen message.
I gave the command posted on your last post and now I have two files .conf (’ i2c-dev.conf ’ and ’ i2c-piix4.conf ')… maybe do I need to delete i2c-dev?

Check dmesg or journalctl and see what is or isn’t loading. You can also look at lsmod rto see what modules are used.

On my AMD system i see in lsmod


Using lsmod, it seems to be loaded but used ‘0’, and both dmesg and journalctl does not print me nothing about it (I have got an AMD too)…

That’s what mine shows also.

Edit: Did you try a different route by adding it to the command line on boot?

What does this show currently and are you using systemd boot or grub?

cat /proc/cmdline

I don’t know how to do it…

I checked the command but I’m not sure to post the print right here… is it safe?

I suppose to use grub (I never touched the defalult settings after the installation of EndeavourOS)…

Sorry try this instead and post the url.

cat /proc/cmdline | eos-sendlog

Did you select grub when you installed? The default is systemd-boot now. I’m not sure when you installed it?

december… when I enter linux, the grub window raises at the boot…

About the cat command:

(Anyway, if the URL is public, I guess it is not so safe…)