Qbittorrent won't launch after update to Plasma 6

Sorry in advance, I’m new to the forum but having been using EOS for over a year now. After the big update to Plasma 6, qBittorrent will not launch. I tried to launch it from my terminal and it seems to just give up and exit the prompt. There were no error messages or anything useful at all. Launching it from the GUI is equally useless as you would expect. I’m not using a third party package either, I’m using the package from the Arch repos. I’d appreciate any guidance anyone may be able to offer. Thank you!

This is a long shot, but check if you have qt6-wayland installed.

1 Like

It is installed. It was worth a shot though.

Does the same behaviour happen when you use a fresh user?

Sorry, I just have the one user account. How would I go about testing this?

Can you post the contents of /usr/local/etc/rc.d/qbittorrent? Does that file exist?

In settings down towards the bottom of the list is the user accounts, create a new account here (the option is at the top of the screen) and log out then into this account.

1 Like

It says file or folder does not exist.

1 Like

You were on to something. It launches just fine under a different user account.

It is a bit strange that the app doesn’t launch and yet there are no error messages printed out on the command line.

If you run journalctl -f and then try to launch the app, does the are there any new journal entries logged?

It will be either a setting you have in qbittorrent or a theme issue then I’d think. You can restore the defaults by deleting the qbittorrent folder under .config in home.
If you have any custom themes installed turn them off/revert to breeze.

3 Likes

That fixed the issue, I don’t believe I was using a custom theme. Settings maybe, I had it configured a weird way I suppose.

I didn’t see anything that looked out of the ordinary, aside from org.kde.plasma.appmenu throwing up a bunch of errors.

Cool, awesome that you have solved it. I reset a lot of apps and theming to default before upgrading to avoid as many issues as possible.

2 Likes

It just occurred to be, I changed my system locale to a different language because it helps me practice said language. qBittorrent started up in that language which I did not expect. Could that have caused the issue?

Maybe but I’m not technically minded enough to be certain. I’m just well versed now at getting myself out of trouble lol

I pretty much live by the same philosophy lol. In my now 4-5 years using Linux I’m always finding new ways to break things as well as fix them.

1 Like

Best way to learn in my opinion, some hands on experience

Most definitely, never minded getting my hands dirty.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.