qBittorrent doesn't look OK

Renders fine in Manjaro.

Looks fine to me here: (EOS - xfce)


A little more of what’s wrong might let us help…

1 Like

Running XFCE too, and Nvidia.

Still can’t tell what the problem is - my eyes are old, perhaps that’s the difficulty? Can you describe it, and is it a new problem?

Open the screenshot and look at the left column. Parts of it are missing.

I think I understand. On manjaro the application is themed the same as the rest of the desktop environment. Most likely because that app is gtk2 or 3 dependent and manjaro installs both for you. On endeavor os this is left up to you. It’s your experience to create. Try using the arc-dark theme included with eos and see if that helps.

1 Like

I think it is the opposite. The OP is using xfce and qbittorrent is qt based.

Still…not rendering parts of the app is a messed up theme problem :slight_smile:

You are right though, I would try changing the theme first.

1 Like

Solution: https://bbs.archlinux.org/viewtopic.php?id=255130

In the last post: ‘I’ve added “QT_AUTO_SCREEN_SCALE_FACTOR=0” to ~/.pam_environment.’

That doesn’t work for me. Works when I run ‘QT_AUTO_SCREEN_SCALE_FACTOR=0 qbittorrent’ in a terminal.

Try putting it in /etc/environment

2 Likes

I meant the comment about my eyes - even opened I couldn’t increase magnification on that screen sufficiently to be sure of what it was! QT theme probs OK…

Thanks, but doesn’t work.

Is it being overridden by something else?

What is the output of env | grep -i qt

No output.

Can I see what you put in /etc/environment? Also did you reboot after changing that file?

1 Like

This file is parsed by pam_env module

Syntax: simple “KEY=VAL” pairs on separate lines

QT_AUTO_SCREEN_SCALE_FACTOR=0

No didn’t reboot. Will try. Thanks :smiley:

Rebooting fixed it. Thank you :smiley:

1 Like