Python update broke GWE with no apparent resolution at the moment, any suggestions? I need to overclock my Nvidia GPU

I use GWE to overclock my GPU.

Looking on the AUR, there’s no resolution for this now (look at recent comments): https://aur.archlinux.org/packages/gwe/

There were some issues filed:

Anyways, being new to EOS, I’m wondering what suggestions everyone has. Is it worth it to just downgrade Python? If so, is there a way to block updates for now up until this is resolved?

Or is there another way to overclock and undervolt my GPU along with fan control?

This is urgent for me, so I may need to go back to Windows for the meantime if there’s no good resolution.

Well hello again! As you can see from the issue trackers, it’s been an ongoing issue for 2 months now. I doubt there’ll be a fix by tomorrow. Perhaps a fix by the end of this week or more realistically by the end of this month, but nothing is ever certain when it comes to issues like this. And since the flatpak doesn’t seem to work as well now, I’d say you don’t have many options. gwe is not a deal-breaker for me, I don’t overclock myself, so I can’t offer the best advice other than to wait and see. Downgrading could be an option, but I don’t think many users would recommend partial upgrades since that could lead to a whole other set of issues. Hopefully some other users have more solid advice to offer, but I don’t think I offered much good news for you, sorry about that!

1 Like

I would try a downgraded Flatpak version; at least this should isolate the python 3.10 issue. For info on how, check my answer here: https://unix.stackexchange.com/questions/552688/is-it-possible-to-roll-back-a-flatpak-update/552700#552700

1 Like

Hey again @Scotty_Trees - no worries, I don’t expect an immediate fix, and actually what I asked for was a workaround solution which I’m still hoping for :slight_smile: I would rather not need to go back to Windows since I’m pretty used to things on Linux/EOS at the moment.

@ajgringo619 Thanks for the suggestion. I did revert to a couple of lower Flatpak versions with the help of your instructions, but it came up with the same error in Flatpak as before about the NVLM Shared Library not being found. But, I may not have the knowledge needed to understand which version I should be reverting to :frowning:

1 Like

I don’t overclock but it looks like the Arch wiki lists a couple of options. Maybe one of those could work for you?
https://wiki.archlinux.org/title/NVIDIA/Tips_and_tricks#Enabling_overclocking

Saving overclocking settings

Typically, clock and voltage offsets inserted in the nvidia-settings interface are not saved, being lost after a reboot. Fortunately, there are tools that offer an interface for overclocking under the proprietary driver, able to save the user’s overclocking preferences and automatically applying them on boot. Some of them are:

  • gweAUR - graphical, applies settings on desktop session start
  • nvclockAUR and systemd-nvclock-unitAUR - graphical, applies settings on system boot
  • nvocAUR - text based, profiles are configuration files in /etc/nvoc.d/, applies settings on desktop session start
1 Like

Hey, I did look there, forgot to mention :slight_smile:

It looks like these haven’t been updated in a while. But I’m also not clear on how to set the settings exactly how I did like in GWE.

On my 3060TI, I use the following settings:

125 PL
-502 Core clock
1170 Mem
75% fan speed at 65c min

Above all I’m not clear on how to scale fan speed properly like I could before.

Also, looks like there’s Tuxclocker
and according to gwe’s issue page, the flatpack should work as well.

Tuxclocker doesn’t seem to work and it’s also a bit old. The flatpak does not work per the above convo.

it seems that new version is being built right now: https://flathub.org/builds/#/builders/32/builds/70952

Source: GWE AUR

1 Like

Ty Scotty, I’ve also flagged the AUR package for comments… it’s pretty handy

1 Like

PutridPete [1] added the following comment to gwe [2]:

Seems like the update has been pushed into flathub already, so now if
you run flatpak update it should pull the latest version
and restore functionality to GWE. I can confirm the flatpak version is
working again for me.

Source: GWE AUR

@thrik If you give the flatpak version a go, let us know if it works since GWE is crucial to you.

Yeah the Flatpak is working, I already replied to Pete there. Glad he updated on that

1 Like

Anyways, all in all, this was a learning experience. nvidia-settings can handle almost everything except the proper fan control settings, since it can only set the fans at a static speed. Which is nice if everything runs okay, but it’s not ideal in case my computer starts to overheat for some reason.

GWE also shows that there’s a safety kill-switch, that if my GPU reaches 98c, that it will shut it down.

I don’t know if this automatically happens without GWE or not, but it’s nice having that peace of mind.

1 Like

this has been fixed by a small change to python-injector.

2 Likes

Yup, thanks for the heads up @steanne, that fix just got pushed and updated in the AUR. I just updated python-injector and now GWE runs again!

@thrik Dunno if you want to keep using the flatpak version or not, but the GWE AUR package is working again :slight_smile:

Edit: This thread should now be solved btw with the recent update to python-injector

3 Likes

Hmm, I tried running yay to update python-injector, it’s not seeing an update, it wants to reinstall the same version. I’m still getting the same launch problems with gwe as before.

It was only updated about 2 hours ago; it probably hasn’t hit your mirror yet.

1 Like

Actually, it turns out I had some other error launch too lol… No module named 'py3nvml'

But, was able to (re)install that after a Google search by running pip3 install py3nvml.

All is well now. Thanks everyone :slight_smile:

1 Like

And I realized just now that, even though I knew it was an AUR package, I somehow forgot it was an AUR package - so my mirror comment did not apply.

I do drink a lot… :laughing:

1 Like

Strange. I never had to install a package via pip (even now) to use GWE. Can use it without any problems.

2 Likes