Putty crashes on connection

I’m trying to log into a router by a usb serial port adapter with Putty. It connects fine, but when I hit connect the program just dies…

Tried logging in as my user or by root, neither work… I’m lost Thanks

I’ve only used putty to login to machines that aren’t local to me and I connect to my router via a browser like a commoner (this is meant as an insult to only me), so I might not be of much help. One thing that comes to mind though, is the port you are trying to connect on blocked in the router? I guess you would need to be able to connect some other way to be sure, but it’s wroth a try. Also, does putty connect to anything else without issue? Or have you only tried this?

I’ve only tried this, my thought is it’s a group issue as out of desperation I used a windows computer and had no issues. Don’t think it’s a port. But appreciate your thoughts

Yeah, if it works from windows then it’s probably not a port. I don’t know how you would go about finding something else to test with, but that would be a good thing to do. I’m guessing that it’s not an issue with what you are trying to connect to, but possibly something with putty itself when you try to connect. Do you know what package you installed? I have putty 0.74-1 installed and it’s been working fine for me.

This might need access rights, e.g. using a udev rule? I assume it has a TTY device under /dev , have you checked its permissions?

1 Like

Sthanks for trying, it should be the latest version as I just installed with Pac-Man. Putty does start, I can configure it but when I hit connect the program just died and is completely gone. I’ll keep working on it as my emergency is over, but there will be another! Appreciate your help

Nope, good thought I have not done that but will now

I’m confused. I assume you’re attempting to log in from an EOS system. If so, why would you use Putty? I’d open a terminal and simply use sssh from the command line. If you add -vv to the command, it should give you a good deal of debug information, should help locate where the problem is if it fails as well.

OP says:

which is not quite as straightforward as using ssh.

Yes, using Gnome as a desktop. Program opens just fine, can run all config pages fine, but does and disappears when I try to connect, leaves no log files

It’s an older VoIP box doesn’t support ssh. Has to be a serial connection.

Did you try running PuTTY from a terminal and checking for any output?

These are the 2 errors in the terminal
(putty:58878): Gtk-CRITICAL **: 19:17:54.889: gtk_box_gadget_distribute: assertion ‘size >= 0’ failed in GtkScrollbar
PuTTY: unable to load font “server:fixed”

Have you tried changing the font used to something different? It’s under window > fonts.


Ok that works! I"m sorry for being so slow… Thank you!

1 Like

Excellent, glad it did the trick :smiley: