Pulseeffects constantly crashing

For some reason pulse effects stops working and the sound cuts out all the time since the switch to pipewire. I tried using pipewire by itself and had no problems. Also if I kill pulse effects the sound is immediately restored, so it’s pulse effects that is the issue 100%

It happens all the time. For example if I’m watching youtube videos, I might get to click on a couple then it dies, or if I pause the video it dies, or if I click on anything else that plays audio, it dies. Sometimes it will be frozen and I’ll have to -q pulse effects in the terminal

Does anyone know what the problem could be and how I could fix it? My speakers sound horrible on Linux without an eq

I have had this issue from the start and it caused me to switch to Pulseeffects-legacy. However, recently I decided to switch back because, I guess, pipewire is the future and I figured the issue would be addressed by now. It has not.

The good news is, it has been identified. The pulseeffects developer thinks it might be an issue with gstreamer or something, and plans to fix it but it requires rewriting the code which is going to take them some time. Sort through the github ‘Issues’ for more on this.

I think I may have fixed my issue, which always happened whenever I would use Firefox playing youtube videos. If you pause them or clicked away, all the sound would mute. I would then have to ‘kill’ pulseeffects and restart it, which would cause the app not to run in the background, so minimize and carry on, rinse and repeat.

My fix (hopefully) is that i had enabled in system settings the following; System settings > Accessibility > Screen Reader > Enable Screen Reader.

De-select ‘Enable Screen Reader’, hit apply and reboot. See if that works for you. So far, at least today, I have been able to play videos without losing the sound.


My screen reader was already disabled

It’s good to hear that they’re planning on addressing the issue though

1 Like

Just wanted to update this issue for anyone having the same problem

Pulseeffects changed their name the easyeffects and it no longer crashes

Easyeffects is available in the arch repository but you have to uncomment the community testing section in the pacman config file to install it

1 Like

I am on KDE, and switched to Pipewire and installed easyeffects. The community version would not install, errors. I Installed the easyeffects-git from AUR and that installed. It started up fine, but could not detect any Output sources, so didn’t work. I will be switching back to pulseeffects. thanks anyway for the heads up. I will check back with it later.

This can probably be solved if you open a new thread. :wink:

1 Like

Go to your file system as a root user (I use nemo because dolphin won’t allow it but you can do it through the terminal as well), open the etc folder, click on the pacman.conf file. Locate the following lines and erase the # sign in front of them, then save it

Include = /etc/pacman.d/mirrorlist

Now you can go back to the terminal and sudo pacman -S easyeffects

Once you open it up, it will look empty, you have to click where it says plugins and “add plugin”. The equalizer or whatever you want

1 Like

Thanks for all your help. Just fyi, I didn’t need to activate community testing as the same version is in the normal mirrorlist. Easyeffects finally worked, and Pirewire no longer crashes in Firefox videos/audio, finally. The only issue I found was when activating all the plugins. The more I added, the audio became muffled and low. I did a ‘reset’ in easyeffects and just added the ‘equalizer’ plugin which is all I use anyway, and that works great. :+1:

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.