PSA: Zoom screen sharing under non-Gnome wayland works when joining from your browser

Tl;Dr: If you’re on a wayland setup and don’t want to switch to a X11 session for Zoom screensharing, join a meeting in your browser and share your screen from there.

So at this point the only wayland showstopper for me is the perceived lack of screensharing in Zoom (and for some reason my mostly Linux using office still relies on Zoom for communication :nauseated_face:), which basically meant that I had to maintain both a wayland and a X11 setup. Up until Gnome 41, the Zoom client allowed screen sharing under wayland, but that got removed with Gnome 41.

This basically meant that whenever I needed to join a meeting where I would potentially need to share my screen, I needed to switch session, which is pretty annoying since I usually have a lot of stuff running which needs to stay open. Using only X11 is also not optimal due to the lack of multitouch and highDPI & multi-monitor support, i.e. I would need to switch back after the Zoom meeting.

After ALOT of digging around in various forums, I finally found the solution: While the desktop client of Zoom uses some weird (and now deprecated) Gnome API, the browser version uses WebRTC which works on wayland via pipewire. On my EOS installation this worked out of the box which was pretty neat.

As a result of this I can now move fully to wayland, AND be able to share my screen form e.g. a Sway session!

Just thought I’d share this insight to save people digging through countless other forum posts (and also because I saw a few posts here complaining about Zoom not working properly under Gnome 41)

1 Like

Have you ever tried to switch user/session normally from GDM, without logging out your current session? Then you would switch sessions by switching TTYs. This is something that is supposed to work on multiuser OSes Linux.

I haven’t tried that specifically, but now that you mention it I agree that this should work. Yet this still wouldn’t solve the problem of having to maintain both X11 and wayland setups (in my case e.g. with KDE the scaling is always messed up on one of them), which I just want to avoid out of lazyness. :smiley:

Yes. It’s terrible. I experienced it also. My solution was… don’t use Plasma :rofl:
Long live BSPWM!! :crown:

Yes, or im my case: sway for that sweet multitouch xD

1 Like

So I tried to reinstall eos and screen share on different DE, focusing on xorg. Zoom was installed via AUR. I need it for work and teaching.

KDE, gnome and cinnamon, all 3 had odd screen/window flickering. Mate, xfce and i3wm did not have that problem.

On KDE, I could remove temporarily the flickering by changing any of the compositor settings, which is strange and unreliable. I also tried to share via Firefox web app, that didn’t work neither, same flickering.

Out of curiosity, I installed zoom on pop OS 20.04 gnome, and there was no flickering at all during screen sharing. I am wondering if zoom is just optimized for Ubuntu based distros, or only works properly on older iterations of gnome and kde plasma. Don’t know why but it is a big bummer. It means that I can only use xfce, mate or i3 on EOS, and not run my favorite DE.

I only tried on one of my laptops, Thinkpad carbon x1 with Intel Xe graphics, nothing too exotic I think, no Nvidia and such. Am I the only one with that problem on xorg? I am not even thinking of Wayland yet.

Are you using Firefox?

I think the Zoom devs focus (as in care about) Ubuntu/Fedora, i.e. Gnome which is why you will have the best experience there. Which doesn’t mean that it runs great there. In my experience Zoom just runs badly in general on Linux.

As far as the flickering goes, I didn’t experience that bug in particular, but outside of Gnome I experienced all sorts of strange behavior (i.e. on i3 it spawns the home-window with 3x my screen size). If it were up to me I wouldn’t use it at all. Not because it’s proprietary, just because its the worst (professionally made) piece of software I’ve ever touched…

Are you using Firefox?

I’m using Firefox, yes. AFIK there are some problems with Chrome, but Firefox should work fine with pipewire (I suspect that the flickering you’re experiencing is a compositor issue. You could try screensharing from your browser with some other tool, e.g. Jitsi, to see if you can reproduce it)

For me it worked ok, last year there was a problem in getting kicked out from breakout rooms but this seems to have been fixed. Audio/video is ok for me, also sending meetings and adding to calendar.

However screen sharing is impossible on gnome or kde. May have to check if somehow it’s my Intel Xe if you say screen sharing is working no problem. It doesn’t seem to work out well on arch on these DE. The flickering to clarify includes flipping from one window to the other, it’s just a mess.

If you are using a high dpi screen that should be fixable. You can scale qt or gtk apps and I believe you can even change scaling in your .local zoom folder config. zoomus.conf has a Scalefactor that can be changed.

Something along those lines can also work in general for high dpi issues.

1 Like