PSA about lib32-amdvlk on nvidia system

I just found out why I couldn’t run Elden Ring or Tomb Raider (2013), while a number of other games worked just fine. The reddit thread below put me on the right path. I had lib32-amdvlk installed. Uninstalling it instantly fixed both those games.

I checked the logs, and it was installed a second before, and likely as a dependency for, steam:
https://archlinux.org/packages/multilib/x86_64/steam/

So this is a nice little trap… I’m not sure how I would have figure it out if I had not been lucky enough to run into that thread…

It is a possible dependency for steam. While installing steam, the installer asks you which graphic libs to install. You maybe installed amdvlk instead of nvidia-utils.

3 Likes

Seems that way, doesn’t it?

I don’t remember doing it at the time, but that doesn’t mean much. Anyway, the point is, so long as that package is there, it preempts its nividia counterpart and OOOOOHHHH

… I just realised that’s why Steam still reported MESA as my video driver; that was bugging me… but other places reported the correct version, so I didn’t worry overmuch… (now it reports Nvidia, as expected)

… maybe that’s because Steam is 32 bits — so is EAC, iirc; so that would match Elden Ring online being a problem (it worked with EAC deactivated).

Things start making sense…


Additional Note: I didn’t install amdvlk, just lib32-amdvlk during steam installation; which was from a script with --noconfirm.

So elder ring now works without the flat pack version of steam?

Elden ring runs fine for me. 5800x 6700xt I just install steam (not native) and vulkan-radeo then enable beta access to steam and use proton experimental.

I can make it work only on flatpak steam, strange