Protonvpn not working

Hey I am using sway . I have installed protonvpn using yay (both cli and gui).

  ~ protonvpn-cli c
Traceback (most recent call last):
  File "/usr/lib/python3.11/site-packages/protonvpn_nm_lib/core/keyring/", line 21, in __getitem__
    stored_data = self.__keyring_backend.get_password(
  File "/usr/lib/python3.11/site-packages/keyring/backends/", line 78, in get_password
    collection = self.get_preferred_collection()
  File "/usr/lib/python3.11/site-packages/keyring/backends/", line 61, in get_preferred_collection
    collection = secretstorage.get_default_collection(bus)
  File "/usr/lib/python3.11/site-packages/secretstorage/", line 177, in get_default_collection
    return Collection(connection)
  File "/usr/lib/python3.11/site-packages/secretstorage/", line 45, in __init__
  File "/usr/lib/python3.11/site-packages/secretstorage/", line 67, in get_property
    (signature, value), = self.send_and_get_reply(msg)
  File "/usr/lib/python3.11/site-packages/secretstorage/", line 48, in send_and_get_reply
    raise DBusErrorResponse(resp_msg)
jeepney.wrappers.DBusErrorResponse: [org.freedesktop.DBus.Error.UnknownObject] ("No such object path '/org/freedesktop/secrets/aliases/default'",)

During handling of the above exception, another exception occurred:

Traceback (most recent call last):
  File "/usr/bin/protonvpn-cli", line 33, in <module>
    sys.exit(load_entry_point('protonvpn-cli==3.13.0', 'console_scripts', 'protonvpn-cli')())
  File "/usr/lib/python3.11/site-packages/protonvpn_cli/", line 21, in main
  File "/usr/lib/python3.11/site-packages/protonvpn_cli/", line 65, in __init__
    res = getattr(self, args.command)()
  File "/usr/lib/python3.11/site-packages/protonvpn_cli/", line 71, in c
    return self.connect()
  File "/usr/lib/python3.11/site-packages/protonvpn_cli/", line 133, in connect
    return self.cli_wrapper.connect(args)
  File "/usr/lib/python3.11/site-packages/protonvpn_cli/", line 242, in connect
    if not self.protonvpn.check_session_exists():
  File "/usr/lib/python3.11/site-packages/protonvpn_nm_lib/", line 356, in check_session_exists
    return self._env.api_session.is_valid
  File "/usr/lib/python3.11/site-packages/protonvpn_nm_lib/core/", line 56, in api_session
    self.__api_session = APISession()
  File "/usr/lib/python3.11/site-packages/protonvpn_nm_lib/core/session/", line 264, in __init__
  File "/usr/lib/python3.11/site-packages/protonvpn_nm_lib/core/session/", line 293, in __keyring_load_session
    keyring_data_user = ExecutionEnvironment().keyring[
  File "/usr/lib/python3.11/site-packages/protonvpn_nm_lib/core/keyring/", line 32, in __getitem__
    raise exceptions.KeyringError(e)
protonvpn_nm_lib.exceptions.KeyringError: [org.freedesktop.DBus.Error.UnknownObject] ("No such object path '/org/freedesktop/secrets/aliases/default'",)

I have looked it up and installed gnome-keyring and kdewallet but no use

Not using protonvpn-cli/gui here but just had a look at gnome-keyring’s ArchWik page.

It says:

libsecret should also be installed to grant other applications access to your keyrings. Although libgnome-keyring is deprecated (and superseded by libsecret), it may still be required by certain applications.

Perhaps you could try installing these two packages and see if you can get it to work.

A reboot might not be needed bu works a miracle sometimes :wink:

Nah ! It didn’t work , I have reinstalled it but it’s not working

Do you have network-manager-applet installed? I read in the AUR packages repository (comments) and on Protonmail’s site, I think, and I had to install it so that it works in Gnome.

Also, if it doesn’t work, you can use the non official protonvpn or you can use openvpn.

1 Like

can you say how i can use
openvpn . Is it free vpn ? . I just need them to bypass my university’s restriction

Did you try to install network-manager-applet? It doesn’t solve the problem?

The second solution is installing protonvpn-cli-community from the AUR. That’s what I use with ARM on the pinebook pro, where I can’t get the official protonvpn-cli to work.

I also tried the third way, openvpn, also though protonvpn. They have a good guide to setting it up here: