ProtonVPN client issues

I wanted to try out the official ProtonVPN client on Endeavor, so I followed their official installation instructions for Arch/Manjaro. After the installation, no matter if I’m running the VPN service or not, I can’t put my system to sleep or hibernate without losing the ability to connect to my network. The types of errors I get in my tray are things like “Missing VPN plugin”, “Failed to activate connection”, “failed to deactivate connection”, “Failed to get secrets”, and “Captive portal detected”. I read that this can be due to IPV6leak protection built into the VPN killswitch, so I followed the official protonVPN instructions on deactivating that with no luck. The only thing that showed in my nmcli connections table as active was my ethernet connection. I also tried looking at my ifconfig table and still no luck. This is both on a fresh reboot and after a sleep cycle. Completely purging ProtonVPN from my system does not change anything. I contacted Proton and was basically told I was on my own since Endeavor is not an officially supported platform. So, I’m coming over here to try and figure out what I can due to fix the issue.

Any help would be massively appreciated.

Thanks for giving EndeavourOS a try, and welcome to the forums. I hope you enjoy your time here.

Click on the EndeavourOS logo on the upper left side of the header.
Then click on “All catagories”, then click on “General System”, and finally click on “All” and scroll down to “Gaming”

Once in the gaming category, click on the magnifying glass and search for proton.
The first result listed may help you. It should be titled " Linux gaming [Guide]"

If not post back with questions.

Pudge

Thanks for responding Pudge. This is not for Steam’s Proton compatibility tool. This is for the Protonmail VPN client.

Easy mistake.

For getting the ProtonVPN client to work, did you install via the AUR package protonvpn-gui? I’ve found that package works just fine for my systems (2 EndeavourOS systems).

For the issues that it caused, sorry, can’t be of much help there at all. I haven’t had any issues with the client on either of my systems after installing via the AUR.

Yeah, used the official instructions, which are pamac search --aur protonvpn, Verify PGP keys, and install.

There are apparently multiple different people on different distros that have had similar issues. A guy I talked to on Mint resorted to an OS reinstall. I hope it doesn’t come to that lol

I tried the GUI for ProtonVPN not long after it was released for Linux, and found several glitches. Since then I’ve stuck to protonvpn-cli from the AUR. You could use this as a temporary workaround, as if multiple people on different distros are having issues, it sounds like ProtonVPN need to fix the app.

Yeah, I wish they’d have let me send them my log files or something.

But, yeah, I’m still having issues despite having completely purged ProtonVPN from my system. I’m wondering if there’s a config file that’s been modified somewhere personally…