Proton 5.13-1

After a little amount of time away from Linux gaming I decided to fire up some games that are now compatible with proton 5.13-1.

Unfortunately, when I try to start a game with that version of proton it immediately crashes/exits. It doesn’t seem to matter which game it is.

I tried both steam-runtime and steam-native and the behavior appears to be the same.

Other versions of proton seem to work fine.

Since it has been a long time since I set configured this install I don’t really remember everything I did but here is some general system info:

Graphics:  Device-1: Advanced Micro Devices [AMD/ATI] Vega 10 XL/XT [Radeon RX Vega 56/64] driver: amdgpu v: kernel 
           bus ID: 44:00.0 chip ID: 1002:687f 
           Display: x11 server: X.Org 1.20.9 compositor: kwin_x11 driver: amdgpu unloaded: modesetting 
           alternate: ati,fbdev,vesa resolution: 1: 2560x1440~60Hz 2: 2560x1440~60Hz 3: 2560x1440~60Hz s-dpi: 96 
           OpenGL: renderer: Radeon RX Vega (VEGA10 DRM 3.39.0 5.9.1-arch1-1 LLVM 10.0.1) v: 4.6 Mesa 20.2.1 
           direct render: Yes 
>> pacman -Qsq amd                                                                                                                            
>> pacman -Qsq vulkan                                                                                                                              
>> pacman -Qsq steam                                                                                                                               

Maybe I am missing some required packages? Any idea how I can troubleshoot this further?

1 Like

I don’t see the AMD Ucode.

The only packages I install are steam not runtime not native just steam. Amdvlk because vulkan Radeon has some issues with proton / glorious egg roll. And lib 32 that the steam install prompts you to. Then I install game mode.

I tried removing steam-native but it didn’t seem to make any difference. The same for installing gamemode and lib32-gamemode

Is Proton 5.13-1 working for you?

1 Like

Let’s see the log, perhaps it will shred some light:

The first game i tested with it was death stranding and it worked. Going to install red dead redemption2 ina bit to see if that works @keybreak

1 Like

Hmm…I don’t see any errors:

Proton: 1602709129 proton-5.13-1b
SteamGameId: 242050
Command: ["~/.local/share/Steam/steamapps/common/Assassin's Creed IV Black Flag/AC4BFSP.exe", '-uplay_steam_mode']
Options: {'forcelgadd'}
1 Like

Which games? If i have them I can try them.



I tried AC IV, Torchlight and Magic 2014 but I suspect if I tried others it would be the same.

Yeah that’s weird, can you try latest GloriousEggroll?
Just to exclude Proton itself, if it doesn’t work too…Or confirm it doesn’t work :slight_smile:

I will try gloriouseggroll(once I lookup how to do that).

However, all other versions of proton seem to work fine.

It’s very easy, check my guide here:

Specifically Install custom Proton engine bullet from that link
With GE or TKG you at least will be able to play your latest games i think

However, all other versions of proton seem to work fine.

Oh, well that probably mean that it’s specific version of Proton is crapped :frowning:
I mean it’s extremely weird that there are no log at all

btw i assume you’re up to date, but just in case:

gcc --version

GE works, but AC IV doesn’t finish launching which is something that was supposed to be fixed in 5.13-1.

gcc (GCC) 10.2.0
Copyright (C) 2020 Free Software Foundation, Inc.
This is free software; see the source for copying conditions.  There is NO

Is this Manjaro Stable?
I think it should be ahead on Arch and latest Proton depends on more recent version, that must be a reason…

Oh, then try TKG :frog: , it’s 5.19 should be fixing it (i think):


>> yay -Syi gcc                                                                                                                 
:: Synchronizing package databases...
 archzfs is up to date
 archzfs-kernels is up to date
 core is up to date
 extra is up to date
 community is up to date
 multilib is up to date
 herecura is up to date
Repository      : core
Name            : gcc
Version         : 10.2.0-3
Description     : The GNU Compiler Collection - C and C++ frontends
Architecture    : x86_64
URL             :
Licenses        : GPL  LGPL  FDL  custom
Groups          : base-devel
Provides        : gcc-multilib
Depends On      : gcc-libs=10.2.0-3  binutils>=2.28  libmpc
Optional Deps   : lib32-gcc-libs: for generating code for 32-bit ABI
Conflicts With  : None
Replaces        : gcc-multilib
Download Size   : 31.53 MiB
Installed Size  : 147.32 MiB
Packager        : Evangelos Foutras <>
Build Date      : Wed 30 Sep 2020 02:38:18 AM CDT
Validated By    : MD5 Sum  SHA-256 Sum  Signature

Does your mirror show something different?

1 Like

That’s what mine shows.

Weird, i have the same…Sorry maybe i’ve mixed something, trying to find where i’ve read about it yesterday

Not what i was initially referencing, but here’s some stuff that i found (let’s dive in :laughing: ):

which leads to this

Looks like this Proton release is not very well made…

That’s so weird though, a lot of people got it working on Arch with both Nvidia / AMD, for example here it’s evident:

What are we doing wrong?! :thinking: