Proper link negotiation settings in network connections?

On KDE Plasma network manager settings under Connections, “Link Negotiation” is set to “Ignore” by default, which grays out Speed and Duplex.

I have a 2.5 GB NIC and I want to be sure I’m getting the maximum speed. Should I change Link Negotiation to “Manual” and specify “2.5Gb/s” for the Speed setting?

Should “Duplex” be set to “Full” or “Partial”?

Or is setting Link Negotiation to “Automatic” ideal?

Usually while somewhat misleading “Ignore” should be fine and negotiate the optimal connection speed.

A quick check on KDE is to look at the network widget:

Another way is dmesg, e.g.:

❯ sudo dmesg | grep -i duplex
[   15.222680] igc 0000:06:00.0 enp6s0: NIC Link is Up 1000 Mbps Full Duplex, Flow Control: RX/TX
1 Like

This is an excellent tip! Mine says 1 GBit/s, but my NIC is 2.5 GBit/s. It’s connected to a switch which maxes at 1 GBit/s, so I’m good.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.