Problems with system clock on login screen

I have a problem where the clock on my login screen is an hour ahead, yet when I log in to the system, the clock in the taskbar is correct.

With us being in BST (GMT+1) at the moment, how can I ensure I am in sync?

I have NTP enabled.

Thanks!

what is the output of timedatectl status ?

1 Like

https://wiki.archlinux.org/index.php/System_time#System_clock

timedatectl

           Local time: Sat 2019-08-17 15:49:32 BST
       Universal time: Sat 2019-08-17 14:49:32 UTC
             RTC time: Sat 2019-08-17 14:49:32
            Time zone: Europe/London (BST, +0100)

System clock synchronized: yes
NTP service: inactive
RTC in local TZ: no

1 Like

ok timedatectl look ok then, are you behind any vpn ? timezone looks ok

Are you running a dual boot Windows and Linux?

as root, should get this

# timedatectl status
               Local time: Sat 2019-08-17 17:42:46 MDT
           Universal time: Sat 2019-08-17 23:42:46 UTC
                 RTC time: Sat 2019-08-17 23:42:47
                Time zone: America/Denver (MDT, -0600)
System clock synchronized: yes
              NTP service: active
          RTC in local TZ: no

Notice in particular “NTP service: active”
if it says NPT service: inactive, enter the following as root

# timedatectl set-ntp true

then recheck timedatectl status

Pudge

3 Likes

Fantastic, that worked!

timedatectl status

           Local time: Sun 2019-08-18 01:48:56 BST
       Universal time: Sun 2019-08-18 00:48:56 UTC
             RTC time: Sun 2019-08-18 00:48:55
            Time zone: Europe/London (BST, +0100)

System clock synchronized: yes
NTP service: active
RTC in local TZ: no

Here is a handful of hopefully helpful hints. Say that fast 3 times.

If this solved your problem, in the post that contained what you consider to be the solution, click the “solved” button. I think it is labeled solved. Then in your original post it shows your problem is solved, plus it lists the post that solved it so someone reading the post for the first time can click and go straight to the solution.

Anytime you start a line with # such as a command as root (# timedatectl status), the forum software sees the # as a command to print big bold letters. To eliminate that, at the beginning of the line, put 4 spaces, then your # timedatectl status and the print will be normal size.

Also the forum software re-formats a lot of what you type, such as your output listing of the timedatectl command. Trying to make a chart is frustrating. To eliminate this, in the very upper left of a qwerty keyboard, just below the Esc, is a key with a backwards single quote and when shifted is the tilde.
Put three of backwards single quote (I’m sure there is a name for this character) on an empty line. hit return and type in a chart, or paste in the output of a command from the terminal, then Enter and three more single quotes followed by an Enter. The forum software will leave all the formatting exactly like you typed it.

Start a reply, play with these to see how they work, then cancel the reply.

HTH
Pudge