Problems with shutdown

Good evening, I come to ask for your help for a problem that is happening to a friend that I invite to the linux community and of course to endeavouros, it happens that he has the following problem, he has the following PC:
core i5 3470 3.20 3.60
12gb ram
gt1030 2gb GDDR5 brand ARTEK
kingston ssd 120gb 30mbs
hdd 1tb hitachi

You can use your pc perfectly with your nvidia graphics and all without news, the problem is when you want to turn off the pc, the pc stays in an infinite loop and never turns off in the process he always leaves the same lines, I will leave image below

I tried the possible solution I saw in this forum and others, which was to modify the mkinitcpio and add “shutdown” to the hook and generate everything again, but it didn’t work. The experience is normal, the only problem is that you can not turn off the pc, but if you can reboot, lock screen play games and all also tried with the command ‘poweroff’ in console and did not help either, I hope someone can kindly provide a solution, and thanks for reading all this

Can you post a link for the following:

sudo dmesg | eos-sendlog
sudo journalctl -b-1 | eos-sendlog

To be quite honest - it would be a million times easier for us to help your friend, than you. As a middle man, you will likely not be able to answer in any worthwhile way. Just tell them to sign up here, send them this link and have them post. It will save all of us a huge amount of work.

1 Like

In fact, I am quite active and he is a friend that I have known for a long time, the problem is that he has a hard time with English and he doesn’t know much about linux either, I am explaining to him little by little, I will upload the requested information as soon as possible.


Here is the requested information, feel free to ask me anything else

Maybe someone else can gleen some more info from the logs. I can’t really tell. I see sddm crashes a few times but I’m not sure what is causing it to not finish the shutdown. Hopefully someone sees something I don’t.

there is this

[    0.531066] ACPI BIOS Error (bug): Could not resolve symbol [\_SB.PCI0.SAT0.SPT0._GTF.DSSP], AE_NOT_FOUND (20210730/psargs-330)
[    0.531074] ACPI Error: Aborting method \_SB.PCI0.SAT0.SPT0._GTF due to previous error (AE_NOT_FOUND) (20210730/psparse-529)
[    0.531081] ata1.00: ATA-9: KINGSTON SA400S37 120GB, FW200326, max UDMA/133
[    0.532036] ACPI BIOS Error (bug): Could not resolve symbol [\_SB.PCI0.SAT0.SPT4._GTF.DSSP], AE_NOT_FOUND (20210730/psargs-330)
[    0.532052] ACPI Error: Aborting method \_SB.PCI0.SAT0.SPT4._GTF due to previous error (AE_NOT_FOUND) (20210730/psparse-529)
[    0.532066] ata5.00: ATA-8: Hitachi HDS721010CLA630, JP4OA41A, max UDMA/133
[    0.532238] ata5.00: 1953525168 sectors, multi 16: LBA48 NCQ (depth 32), AA
[    0.532516] ata1.00: 234441648 sectors, multi 8: LBA48 NCQ (depth 32), AA
[    0.533487] ACPI BIOS Error (bug): Could not resolve symbol [\_SB.PCI0.SAT0.SPT4._GTF.DSSP], AE_NOT_FOUND (20210730/psargs-330)
[    0.533503] ACPI Error: Aborting method \_SB.PCI0.SAT0.SPT4._GTF due to previous error (AE_NOT_FOUND) (20210730/psparse-529)
[    0.533649] ata5.00: configured for UDMA/133
[    0.535387] ACPI BIOS Error (bug): Could not resolve symbol [\_SB.PCI0.SAT0.SPT0._GTF.DSSP], AE_NOT_FOUND (20210730/psargs-330)
[    0.535395] ACPI Error: Aborting method \_SB.PCI0.SAT0.SPT0._GTF due to previous error (AE_NOT_FOUND) (20210730/psparse-529)
[    0.537661] ata1.00: configured for UDMA/133

sddm[433]: Message received from greeter: PowerOff

on second log many checks fails on disk ( power ? status disks ? )

ene 01 18:53:11 MiguelPC systemd[1]: File System Check on Root Device was skipped because of a failed condition check (ConditionPathIsReadWrite=!/).
ene 01 18:53:11 MiguelPC kernel: random: lvm: uninitialized urandom read (4 bytes read)
ene 01 18:53:11 MiguelPC systemd[1]: Starting Journal Service...
ene 01 18:53:11 MiguelPC systemd[1]: Starting Load Kernel Modules...
ene 01 18:53:11 MiguelPC systemd[1]: Starting Remount Root and Kernel File Systems...
ene 01 18:53:11 MiguelPC systemd[1]: Repartition Root Disk was skipped because all trigger condition checks failed.

In windows everything works perfect, the problem of shutdown only happens in linux, and I repeat, the problem is only to turn off, you can reboot, block but when shutting down it remains in that infinite loop.

fastboot is disabled ? :wink:

1 Like

just out of curiosity, if you become root or use sudo, are you able to manually type in any of these with success?

sudo reboot (to reboot your system)
sudo halt (to halt the system)
sudo poweroff (to halt the system and turn off the power)

On one system I’m using at the moment, all three of these commands show up in the /sbin directory.
Whether you find them in /sbin or somewhere else, these are command commands to either reboot or turn off your system and they generally work on the majority of Linux distributions. Do they work on your EOS setup?

Do you have Windows installed also?

Edit: Make sure that Windows fast start up feature is disabled in Windows under power options.

All is fine except for shutdown

Right now that pc have only linux

That pc no have windows right now, i only said it as information that in windows there was no error

1 Like

Can you post the following.

inxi -Ga

Edit: Also can you post this

sudo systemctl --failed

What happens if you type in sudo poweroff ?

The same


First command---- Graphics:
Device-1: NVIDIA GP108 [GeForce GT 1030] driver: nvidia v: 495.46
alternate: nouveau,nvidia_drm bus-ID: 01:00.0 chip-ID: 10de:1d01
class-ID: 0300
Device-2: Generalplus 808 Camera type: USB driver: snd-usb-audio,uvcvideo
bus-ID: 1-1.4:5 chip-ID: 1b3f:2002 class-ID: 0102
Display: x11 server: X.Org compositor: kwin_x11 driver:
loaded: nvidia unloaded: modesetting alternate: fbdev,nouveau,nv,vesa
display-ID: :0 screens: 1
Screen-1: 0 s-res: 1600x900 s-dpi: 92 s-size: 442x251mm (17.4x9.9")
s-diag: 508mm (20")
Monitor-1: HDMI-0 res: 1600x900 hz: 60 dpi: 92
size: 443x249mm (17.4x9.8") diag: 508mm (20")
OpenGL: renderer: NVIDIA GeForce GT 1030/PCIe/SSE2 v: 4.6.0 NVIDIA 495.46
direct render: Yes

Second command:
0 loaded units listed.

does the device have any powersaving settings in Bios/Firmware?
In some cases there are settings on power save states like one is to save more power and another with less, and it could have option to disable the bios settings for that completely and let OS handle it…
I see some devices where this issue happens when settings are on low powersaving or the option is enabled at all.

Maybe try this kernel parameter in the default grub command line and then update grub.