Problems with re-size in VirtualBox (Running on Windows 10, inside Oracle VirtualBox)

Hello,

I’m running EndevourOS with i3 inside a VirtualMachine on Windows 10 (since I want to customise my theme and settings and I don’t want to do that in my live enviornment). I have everything running but even though I inserted “Guest Additions CD Image” and tried to install it with “yay” inside i3 I can’t get the screensize to change when I scale the VM window. It sadly also doesn’t work when I go into “View” and under “Virtual Screen 1” try to change the size.

I have followed the documentation on the main website how to get EndevourOS running in a VM, but still no luck. Does anyone happen to know what I might be missing / doing wrong?

Below are my settings:

Let me re-phrase my question… :wink:

Can you show the output of command

pacman -Qs virtualbox

in the guest?

And in the host, do you have https://download.virtualbox.org/virtualbox/6.1.10/Oracle_VM_VirtualBox_Extension_Pack-6.1.10.vbox-extpack installed?

1 Like

Hello!

I didn’t have the extpack installed I do now, not sure if I need to do anything extra to use it though?

And the output of pacman -Qs virtualbox says this:

local/linux 5.7.7.arch1-1
  The Linux kernel and modules
local/virtualbox-guest-dkms 6.1.10-1
  VirtualBox Guest kernel modules sources
local/virtualbox-guest-iso 6.1.10-1
  The official VirtualBox Guest Additions ISO Image
local/virtualbox-guest-utils
  VirtualBox Guest userspace utilities
```

Have you adjusted the resolution inside EOS itself? I don’t use i3 myself, but it looks like

xrandr --output OUTPUT --mode MODE

Where OUTPUT is the name of your output and MODE one of the available resolutions in the format WIDTHxHEIGHT . You can get both from the output of:

xrandr --query
1 Like

I have never used that before (it used to work so when you make the VM window bigger the running os also scaled to that new window size).

However, it did solve my issue! Running this: xrandr --output VGA-1 --mode 1920x1080 changed the size! :slight_smile: Thanks for the help!

Great, glad it’s working :smiley:

xrandr gui is also there to do so (arandr)

Welcome aboard!

welcome @mukesh

Thanks