Problems with PCI passthrough Qemu

Yes I have all the virtual stuff in the bios on.


error starting domain: unsupported configuration: host doesn’t support passthrough of host PCI devices

I made the directory.
sudo mkdir -pv /etc/libvirt/hooks/qemu.d/win11-clone-passthrough/prepare/begin/

Opening in Nano shows empty with a red bar…

How does it not exist when it literally exists? What retarded crap is this?

Umm, I probably won’t be able to help much further but what is in the file?

Nothing because I had to manually create it.

I thought as much I don’t know what should be in this script but an empty script is useless most the time

I am following guides…

The issue is, this is already there for the teacher, it’s not there for me, this is the major problem with Linux in general.

This video is almost 2 years old at this point I didn’t continue watching after noticing this as it would more than likely have outdated info

Better off using the arch wiki and endeavour wiki than youtube. It may be a bit harder to understand at first if you are a visual learner but all in all they are quite straightforward and to the point

1 Like

Or just use Windows.

1 Like

??? why? I was simply pointing you to help and away from potential outdated/misinformation. If this is how you solve things good luck and see you soon
Also your solution isn’t one it just giving up (sorry but I don’t want others who read this to get confused by finding this as the answer)


I created a new problem by wanting to use Linux, so solving the problem is returning to Windows.
Everything is outdated, unfollowable and literally will send you into a number of hours of work all just to play 1 game.

Seriously how old are you, you sound like a little kid throwing a tantrum at the moment, just because yt is out of date does not mean this couldn’t have been solved. No one here earns any money trying to help so maybe show a bit of gratitde instead of this BS.


I can just install Windows.


I am grateful everything has worked the way it has, EndavourOS is fantastic, I need to install Windows for stuff to function correctly that don’t on Linux.

When down time becomes work time, it feels no different than being at work.

Different strokes for different folks.

I put in enough work and don’t care anymore.

Go to Preferences > Users, then add username to “Ignored” and “Muted”.

I currently have 6 people in both. Forum life is better here. :wink:

Oh sorry, 7…

Imagine an Operating system makes you biased to how you treat an individual.

I have freedom of choice like everyone, my choices don’t have to follow other peoples advice, if this makes you feel personally hurt, then is it me that needs to tell them my age?
Do you know what mental and personal autonomy is?

Emotional regulation and maturity, also recognizing it’s just software… not a place that you should wrap your personality up in.

Another reason people stay far away from places that have folks like yourselves present as they fear the emotional backlash.

1 Like

Just out of curiosity how long have you used Linux, I imagine it wasn’t long?

I will not disclose anything further to avoid the emotional trap you are planting which is about boosting your own sense of ego and self to have a way of getting at me rather than respecting my decisions.

I am not trying to do anything, that’s in your own mind. All I was about the point out it takes about at least a year to learn a new os depending on how much time you have to spend on it, back when Linux was harder to work with it took me about a a year and a half. If you leave out learning an os but apply that to anything in life, it takes at least a year of dedication to something in life to see results. You can’t wake up one day and decide you will know how to to do something without experience, you didn’t come into this world knowing how Windows worked, you learned over time.

Yes everyone has freedom of choice, so do you. Good luck with everything and your future endeavors!

I’ve used qemu a bit but i was always a virtualbox user before. There have been issues over time with different things that made me switch back to vmware and that is what i mostly use. I have never used PCI passthrough as i haven’t found any reason for it and I imagine it’s not as simple as i would want it to be to set it up and get working. What ever your choices are they are yours to make. Hope to see you stick with EndeavourOS however you want to use it. If Windows does what you want it to do and it’s an easier choice then that’s okay too. Just never give up. :wink:

1 Like

I love the OS, I love using Linux, I love learning it.

There are some things that just don’t make logical sense sometimes and the only real logical workaround is going one step backwards, me going back to Windows for a specific use-case is not in my heart what I want, it’s just what is appropriate at this time as I work a busy schedule as it is.

thank you for sharing your insight. :slightly_smiling_face:

No problem and i fully understand. There are a lot of things that don’t make sense to me at times and it’s mostly due to the way it’s written (arch-wiki) sometimes and not really explained in layman’s terms to someone like myself that maybe lacks some of the knowledge to completely understand it. I work with what i do know and try my best with what i don’t. Sometimes I move on also and just let it be for the time being. Maybe i come back to it at a later date. :slightly_smiling_face:

Edit: Learning is a lifetime journey!