Problems with new installation on DELL XPS - Wayland not available

I just installed endeavouros on my DELL XPS and after rebooting (I’m using gnome) the system is using x11. Id’ like to use wayland. I issued the following commands:
sudo systemctl enable nvidia-resume.service
sudo systemctl enable nvidia-hibernate.service
sudo systemctl enable nvidia-suspend.service

the command
cat /sys/module/nvidia_drm/parameters/modeset
reports Y

I create the file /sys/module/nvidia_drm/parameters/modeset with he the following content:
options nvidia NVreg_PreserveVideoMemoryAllocations=1 NVreg_TemporaryFilePath=/var/tmp

Is there anything I can check in order to enable wayland on gnome?

Please give me (if possible) the commands to execute, It’s not easy for me finding them in the documentation.

Thank a lot,

Has the xps got an nVidia card? Thought they were intel…

Is wayland turned on in the gdm config file? At work, so can’t check, but you need to comment (or uncomment) a line.

Look into the file /etc/gdm/custom.conf and make sure this line:


looks as it should, that is, it look as above.

I confirm that the file contains the line


My xps has a “dual graphics card”, bot intel and nvidia.
Thanks for your support

Humour me, try sddm and see if that works:

sudo pacman -S sddm
sudo systemctl enable sddm -f
# reboot and try gnome wayland

to revert:

sudo systemctl enable gdm -f

with sddm wayland works,
With GDM and the info app I saw the the graphic card listed was the intel one. Perhaps my system is not recognizing my nvidia card and is currently using only the intel one?
Thanks again

with this command

ln -s /dev/null /etc/udev/rules.d/61-gdm.rules

Gnome is using wayland.

Now I can go on with the setup.
Thank you.

1 Like