Problems with clipboard on wayland

Hello, I am on nvidia using gnome, i notused that on wayland the clipboard sometimes wont work. I tried various clipboard indicator extensions. Most of the times when i press one of the entries in the clipboard indicator it will not work. When i go to paste it will paste nothing. The clipboard woth 1 time out of 5. no idea what is going on.

I don’t have Nvidia card so I cannot talk to that.

However on GNOME-Wayland, I use clipboard-history:

It works fine on my end.

There is also gpaste in the repos. Have a go at it and see it works for you.

$ pacman -Si gpaste
Repository      : extra
Name            : gpaste
Version         : 45-1
Description     : Clipboard management system
Architecture    : x86_64
URL             :
Licenses        : BSD
Groups          : None
Provides        : None
Depends On      : gcr-4  gtk3  gtk4  libadwaita
Optional Deps   : wgetpaste: Upload clipboard contents
Conflicts With  : None
Replaces        : None
Download Size   : 258.63 KiB
Installed Size  : 1574.00 KiB
Packager        : Jan Alexander Steffens (heftig) <>
Build Date      : Wed 04 Oct 2023 01:44:07 AM CEST
Validated By    : MD5 Sum  SHA-256 Sum  Signature

that clipboard-history plugin when i enable it, it wont even display on the app bar.

Works just fine on my end.

Screenshot from 2024-03-17 17-42-26

Can’t tell what might be the issue on your side since nothing of what you have tried so far has worked for you.

i isntalled gpanel and nothing changed, still the extension will work when it feels like… most of the times i click on a history item and when i paste it doesnt do anything. this is a clean endeavour install
It is definitely a problem with wayland i jsut dont know how to troubleshoot

Actually, since it works for the rest of us (AMD), I’m pretty sure you should say it’s a problem with Nvidia.

If I’m not mistaken the standard wayland behavior is to forget clipboard content from a window, if the window is closed. I don’t think that’s the root of your problem, but maybe check if that’s the issue before looking somewhere else.

Just copy some text from a window and then close the window. Then try to paste the clipboard content.

What environment are you using? this sounds like it could be caused by your compositor somehow since i think it’s supposed to be what handles basic copy-paste actions.

Make sure first that you have wl-clipboard installed

You could try using wl-clip-persist to make your clipboard persistent (remember clipboard after the application you copied from closes)

It hasn’t been updated in 2 years though and i’ve found it to be quite buggy, so I created a cliphist solution for persistent clipboard. (You need cliphist and wl-clipboard for this to work)


previous="$(cliphist list | head -1 | awk '{$1=null; print $0}')"

cliphist store

current="$(cliphist list | head -1 | awk '{$1=null; print $0}')"

if [ "$current" != "$previous" ]; then
	cliphist list | head -1 | cliphist decode | wl-copy

Save the script as cliphist-persist

Then run it like this:

 wl-paste --type text --watch /path/to/cliphist-persist
 wl-paste --type image --watch /path/to/cliphist-persist