Problems with chrooting

Yesterday my laptop ran out of battery while I was working, and I can’t remember if I was doing an update or not (most probably yes).
Now I can’t boot into my system so I’m trying to follow this post and I have logged into my root partition. I did not mount any efi or boot partition 'cause they weren’t indicated by the lsblk command, it just listed the partitions without telling me what they where. I know the root partition because is the largest in my system.
Now the other problems:
pacman -Syyu outputs

failed to synchonize all databases (invalid url for server)

and failed retrieving file xyz.db from could not resolve host

I tried reinstalling the keyrings, but did not work. Then I tried using directly mkinitcpio -p linux, but command not found.

Any help on how to solve these problems?

UPDATE: updating solved by simply logging in and out

lsblk -f
this should show more information about each device as to mount properly

It doesn’t really give me any more info, just the filesystems. I have the ntfs partition(s), a fat32, an unlabelled one, and the ext4 (root).
The problem with updates is solved by simply logging in and out.

Managed to solve my problems.

  1. if you have problems with could not resolve host and you already verified you are connected and able to ping something from your PC, just log out and log in to chroot. It might just solve it.
  2. Endeavour now uses dracut, so you don’t have the command mkinitcpio, you have to use dracut-rebuild

The guide in the post I linked in my question is still completely valid though if you have mkinitcpio.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.