Problems with browsers

Hi everyone,
i have a problem with chrome and firefox, when i start them they start using 100% CPU. After startup and while i use them they continue to use 100% cpu. Ho provato a fare il downgrade di Firefox ma non ho risolto il problema. I’m running EndeavourOS on a surface pro 4 with modified kernel (linux-surface). How i can solve the problem?
My system is this:

Are you saying an empty browser on the startup page is using 100% or they use 100% as soon as you start actually using them? Are you watching videos?

surface pro 4

A series with models from m3 to i7 Skylake-U…

downgrade di Firefox

Not the right way. Start this browsers w/o any add-ons resp. with fresh profiles for testing!

This has certainly not been the case from the beginning. What change did you make?

When i start the browser, on htop the cpu goes up to 100%, after a few seconds it goes down and goes up again, it isn’t stable. When i use the browser to search the web and load pages, the CPU is high. When i play videos, the CPU increases by 100% (maximum drops to 60%, approximately) and the videos lose framerate. In general, browser usage is slow and bad.

I don’t use firefox. I tried to dowgrade because i have the same problem with chrome. The downgrade did not solve the problem.

I repeat:

Start this browser(s) w/o any add-ons resp. with fresh profile(s) for testing!

Btw., you should use X instead of Wayland, at least testing.

I have tried what you said, i have tried the chromium browser, i have tried to use xorg but the problem remains. I think the problem is not related to individual software. Could it be a kernel problem, a hardware problem, or an OS problem?

Start the browser as a test with these variables for SW rendering!

Tell me if i’m wrong, i created this script in bash and saved it in home, then i ran it but it didn’t fix anything. I tried this script with firefox. Do i try to restore the system with chroot? I don’t feel like reinstalling the system.

It has been an attempt for this problem.

On what?

Is this surface kernel really necessary? AUR and with 5.16 EoS.

I don’t have browser issues. I use Firefox BTW.

I would like to try reinstalling all packages with pacman -Qqn | pacman -S -. Yes, the surface kernel is needful, without it the device will not work properly.

Didn’t understand which version of Firefox are you using? My problem applies to all browsers i install.

Well that would be the version that comes with EndeavourOS.

Can you post the output of inxi -Gx ?
(My guess is that you’re not using HW acceleration for video-decoding thus the problem with high cpu usage)

I tried to install arch linux with recommended drivers and it seems that the problem is solved. It was probably a video driver problem. Now, the output of inxi -Gx is

Graphics:
  Device-1: Intel HD Graphics 620 vendor: Microsoft driver: i915 v: kernel
    bus-ID: 00:02.0
  Display: wayland server: X.Org v: 22.1.1 with: Xwayland v: 22.1.1
    compositor: gnome-shell v: 42.0 driver: gpu: i915
    resolution: 2736x1824~60Hz
  Message: Wayland GBM/EGL data currently not available.

Probably installing the driver would have solved the problem, i followed this guide: Arch Linux - Intel Graphics Drivers - Modesetting VS Intel - YouTube

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.