Problems to install Avogrado software (Chemistry)

Hi, i’m beginer in Arch and tried install the program Avogadro, from git clone AUR.

I dont know how install it.

i get this mensage : => Verificando as dependências de tempo de compilação…
==> Instalando dependências não encontradas…
erro: alvo não encontrado: eigen2
erro: alvo não encontrado: libmsym-git
==> ERRO: “pacman” falhou em instalar dependências não encontradas.
==> Dependências faltando:
-> cmake
-> boost
-> doxygen
-> eigen2
-> libmsym-git
==> ERRO: Não foi possível resolver todas as dependências.

Someone can help…

Assuming that you are on EndeavourOS, did you install through yay?

you can type in the terminal “yay avogadro” (without the quotes)

BTW, welcome to the EndeavourOS forum. I’m sure you’ll find much friendly and to-the-point help and advice here as I have never failed to have.

Thank you.
I’m fell wellcomes here.

i did but appear “nenhum pacote correspondeu à pesquisa” (no package found…).
yay command not works or i don’t know how use it??
ps.: sorry for my bad english. I speak Portuguese and is the language setup the system.

What do you get when you type
yay -Ss avogadro
I get

$ yay -Ss avogadro
aur/avogadro-git-eigen3 1.2-1 (+0 0.00) 
    Molecule editor and visualizer designed for cross-platform use
aur/avogadroapp 1.93.0-3 (+1 0.13) 
    An advanced molecular editor
aur/avogadrolibs-git 1.93.0.r1846.cdfdf9bd-1 (+2 0.00) 
    Avogadro 2: libraries
aur/avogadro-git 1425272470-1 (+3 0.00) 
    An advanced molecular editor based on Qt
aur/avogadro2-git 1.93.0.r428.59c4dbd-1 (+5 0.00) 
    Avogadro 2: graphical application
aur/avogadro 1.2.0-6 (+14 0.37) 
    An advanced molecular editor based on Qt
extra/avogadrolibs 1.93.0-4 (2.3 MiB 13.7 MiB) 
    Libraries that provide 3D rendering, visualization, analysis and data processing useful in computational chemistry, molecular modeling, bioinformatics, materials science, and related areas

to try installation I did

 $ yay -S avogadro
:: There are 3 providers available for avogadro:
:: Repository AUR
    1) avogadro 2) avogadro-git 3) avogadro-git-eigen3 

Enter a number (default=1): ^C

Didn’t install it because this machine is my work machine.
Hope this helps

daab,Thank you for answer.
Unfortunately, not works. I did the yay command, however i get this mensage in the end of terminal:
“-- Configuring incomplete, errors occurred!
See also “/home/emerson/.cache/yay/avogadro/src/avogadro-1.2.0/build/CMakeFiles/CMakeOutput.log”.
See also “/home/emerson/.cache/yay/avogadro/src/avogadro-1.2.0/build/CMakeFiles/CMakeError.log”.
==> ERRO: Uma falha ocorreu em build().
erro ao construir: %!s(func() string=0x55d626bbae80)
[emerson@ecom-arch ~]$”

I don’t know how fix it.

Did you try removing everything from before first to make it a “clean” install?

yay -Rns packagename

should clean it up, then reinstall and see if it’s any better.

I did and said: target not found.
This: [emerson@ecom-arch ~]$ yay -Rns avogadro
**[sudo] senha para emerson: **
erro: alvo não encontrado: avogadro
[emerson@ecom-arch ~]$

I tried reinstall and get this:
– Configuring incomplete, errors occurred!
See also “/home/emerson/.cache/yay/avogadro-git/src/avogadro/CMakeFiles/CMakeOutput.log”.
See also “/home/emerson/.cache/yay/avogadro-git/src/avogadro/CMakeFiles/CMakeError.log”.
==> ERRO: Uma falha ocorreu em build().
erro ao construir: %!s(func() string=0x561bfa727e80)
[emerson@ecom-arch ~]$

For while i installed another molecular editor (gchempaint).
with yay command and worked.

Tried to install avogadro (option 2 in yay) and yay also reported an error and aborted. Didn’t try the other options anymore. The package may need to be fixed. I hope gchempaint works for you.

Thanks for your attention.

Sadly it looks like you are out of luck, I tried avogadro-git-eigen3/ on the grounds that it was the latest updated avogadro package. But that failed too. :sad:

If you will, you could post a question to the maintainer at:

this package is very long to compile; there is python2 and qt4

Thank you

Thank you, but i don’t how make your suggest. :confused:

do you suggest a link to me do it?

look if was due to a bad build or maintenance problem ,but when I saw the date
of the latest updates of the packages, as many software programs have cleaned up code " by deleting python2 and qt4 which is the problem in your software ,we see it in the manual link". I ask if you are looking for another software of this type but up to date or not

I’m using another software. Gchempaint.