Problems installing Systemback, conflicting files

Hello,

My system is installed in Spanish.
The out come is to long … at the end:

Paquete (4)           Versión nueva  Diferencia neta

libsystemback         1.8.9-4               1.03 MiB
mkinitcpio-live-boot  1.0.0-1               0.00 MiB
systemback            1.8.9-4               1.58 MiB
systemback-debug      1.8.9-4              17.78 MiB

Tamaño total de la instalación:  20.38 MiB

:: ¿Continuar con la instalación? [S/n] 
(4/4) comprobando las claves del depósito                             [--------------------------------------] 100%
(4/4) verificando la integridad de los paquetes                       [--------------------------------------] 100%
(4/4) cargando los archivos de los paquetes                           [--------------------------------------] 100%
(4/4) comprobando conflictos entre archivos                           [--------------------------------------] 100%
error: no se pudo realizar la operación (archivos en conflicto)
mkinitcpio-live-boot: /lib ya existe en el sistema de archivos (es parte de filesystem)
Ocurrieron errores, por lo que no se actualizarán los paquetes
 -> error al instalar: [/home/keos/.cache/yay/mkinitcpio-live-boot/mkinitcpio-live-boot-1.0.0-1-x86_64.pkg.tar.zst /home/keos/.cache/yay/systemback/libsystemback-1.8.9-4-x86_64.pkg.tar.zst] - exit status 1
error al instalar: [/home/keos/.cache/yay/mkinitcpio-live-boot/mkinitcpio-live-boot-1.0.0-1-x86_64.pkg.tar.zst /home/keos/.cache/yay/systemback/libsystemback-1.8.9-4-x86_64.pkg.tar.zst /home/keos/.cache/yay/systemback/systemback-1.8.9-4-x86_64.pkg.tar.zst /home/keos/.cache/yay/systemback/systemback-debug-1.8.9-4-x86_64.pkg.tar.zst] - exit status 1
keos-inspiron3583%

Thank you

We probably need to see the whole output. Why is it trying to install mkinitcpio-live-boot?

Also, put LANG=C before the command so the output will be in english.

It looks like a packaging issue with mkinitcpio-live-boot. That package hasn’t been updated since 2021.

Also, the package for systemback itself has some questionable things in it as well.

How to unistall mkinitcpio-live-boot ?

LANG=C pacman -R mkinitcpio-live-boot

error: target not found: mkinitcpio-live-boot
[root@keos-inspiron3583 ~]#

It failed to install so it probably isn’t installed in the first place.

Sorry but i don’t understand. How it can be then a conflict … if one of them is not present?

It looks for conflicts before it installs. It finds that package you are trying to install will be in conflict with an already installed package so it refuses to install it.

I need to find a way to get systemback, without it i will no be able to stay for longer in Endeavouros …

I tried this with not result:

keos-inspiron3583% sudo -i
[sudo] contraseña para keos: 
[root@keos-inspiron3583 ~]# LANG=C bash pacman-key --recv-key 50B2C005A67B264F --keyserver 'hkp://keyserver.ubuntu.com:80'
gpg: key 50B2C005A67B264F: "Bluewhale Robot <randoms@bwbot.org>" not changed
gpg: Total number processed: 1
gpg:              unchanged: 1
[root@keos-inspiron3583 ~]# exit
cerrar sesión
keos-inspiron3583% LANG=C yay -S systemback-bin
 -> No AUR package found for systemback-bin
 there is nothing to do
keos-inspiron3583%

Have you tried this:

git clone https://github.com/shadichy/systemback-archlinux
cd systemback-archlinux/
makepkg -si

EDIT: Nevermind, that will have the same problem.

This program doesn’t seem highly compatible with EndeavourOS.

The following package cannot be updated due to dependencies that could not be resolved:
 
systemback

If you solely need the following feature:

(Quote from https://github.com/shadichy/systemback-archlinux)

Systemback makes it easy to create backups of the system and the users configuration files. In case of problems you can easily restore the previous state of the system.

My advice, forget systemback. Use the native snapshot features that are available when using a filesystem like btrfs, zfs or lvm instead. You’ll be much happier in the long run.

For example, generating and restoring btrfs snapshots is an instant process which takes less than a second. You’ll only need a restart and are back to where you left off.