Problems connecting to the NAS without a router

I have a NAS that was always connected to my computer directly (10Gb) instead of going through my router.

I’ve reinstalled EOS recently, and I can’t connect to it anymore. It’s probably a silly mistake I’m making, but I’ve done everything I could think of in the past 4 hours and couldn’t fix it.

In my previous installed EOS, I used to run the following to initiate the connection:

sudo ip address add broadcast + dev ens6f1

And after that, I used to either open smb:// or mount it with NFS.

When I check the NAS, it tells me that the ip address is still, and that the subnet mask is I don’t know why I had /24 before, but I tried /16 as well, and it didn’t work.

This is what I get from the ip address command:

6: ens6f1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP group default qlen 1000
    link/ether 00:1b:21:d7:fb:e9 brd ff:ff:ff:ff:ff:ff
    altname enp2s0f1
    inet brd scope link noprefixroute ens6f1
       valid_lft forever preferred_lft forever

The showmount -e command tells me “clnt_create: RPC: Unable to receive”, ping says that the destination is unreachable, and when I try to open the smb path, the file manager says “no route to host”. I also can’t open the web interface of the NAS.

I guess I simply don’t have an active network between these two devices. What should I do?

Thanks for the help!

Don’t set your IP to .0. Pick one of the other 253 available options.

Thanks. It’s working now!
How come it used to work with 0 in the past, but not anymore?

1 Like

I don’t think it could ever have worked that way. Are you sure you aren’t mixing up the subnet with the IP or something?

That’s the exact command I had stored in a bash script in the past and used [relatively] frequently.
Maybe there was something else overriding it in my previous setup without me knowing.

You can also permanently assign the address. You don’t need to do it every time.

Just add the IP address through Network Manager.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.