Problems connecting to DualSense 5 via bluetooth

HI,

I’ve tried to connect a DualSense for PS5 through Bluetooth but the controller is not recognized by EOS as a game controller. It sometimes fail to connnect, it sometimes connects, but I still get an error message, or it sometimes connect, but is not recognized by Steam nor by EOS as a game controller.

I’ve followed this link that explains the necessity of bluez, bluez-utils and bluez-libs and I installed them. I also followed this post to downgrade bluez, bluez-utils and bluez-libs to 5.68 since current versions seems to be problematic.

I added the UserspaceHID=true to /etc/bluetooth/input.conf and ran the line sudo modprobe hid-playstation.

I get the following error when I try to connect it, but the controller “seems” to be connected, has can be seen in the background of the screenshot and on the controller.

The controller indicates it is “connected”, but is not recognized by either Steam or EOS as a Game Controller.

Anybody knows how to fix this? It seems to be a common problem with DualSense Controllers…

EDIT:
A couple of seconds after the controller seems to be connected, it disconnects automatically…

Sony supposedly supplies good drivers for Linux.
Have you tried the package from the AUR?
Sorry, but that’s all I can help as I’m not a PC gamer but own a PS5 and use it in between.

yay dualsensectl

EDIT: I can use it under XFCE like a mouse.
I guess a gamer will have to help you.

I’ve just tried it but it still does not work…

Worth a shot tho, thanks!

I seem to have it working, but I didn’t do any of that stuff that you did. Just activated the bluetooth service and paired it. All the bluez stuff was installed already. I can’t remember if that happened at install time or via the welcome menu.

Edit: Perhaps try doing it via the command line and see what error it spits out.

Edit 2: A new issue I have been having for the last couple weeks though is that reconnecting the controller. It will show that it is connected, but it doesn’t appear to work. Repairing every time makes it work though.

Edit 3: Restarting the bluetooth systemd service seems to also make it work on reconnect.

Edit 4: Using sc-controller from the aur will make it work as an xboc controller as a workaround.

Edit 5: Found the source of my issue https://github.com/bluez/bluez/issues/777

Here’s a screenshot of bluetoothctl connection status with the given error. It’s a simple timeout, I really have no clue of why it’s acting like that.
I have blurred any useless info, but the DualSense has the MAC that looks like 4C:[blurred]:CE. The bond works, but the connection fails.

I’ve tried many times to restart bluetooth.service, without success (same output every single time) manually and through the button popping in the GUI’s error popup.

On the bluez thread you’ve posted, you fixed your problem by switching UserspaceHID=true to UserspaceHID=false or by rolling back bluez to 5.72? Anywho, I guess I’ll try both separately to see if it makes a difference.

I’ll try sc-controller as suggested, but I tought Steam could do the same thing with its Playstation Controller Support feature.

I solved the my issue by setting userspace good variable to false. However, the controller would always pair the first time through the gui. Whenever I would disconnect the controller and try to reconnect the controller later. It would say it is connected, but there wouldn’t be any input. After the initial pairing, does it connect even briefly when you press the playstation button.

I’ve tried changing UserspaceHID to false, but then, the controller is never discovered, both in the GUI and with bluetoothctl -> scan on.
It does look like it’s connected after the pairing (the lights on the controller are lit and EOS indicates it’s connected), but there are no inputs recognized, nor does Steam see it as a Game Controller…

Are you making sure making sure to put the controller into pairing mode?

Wanna use discord or rustdesk?

Pretty sure since it appears as discoverable in bluetoothctl CLI. We could, but I really think the problem is actually a bluetooth issue and wanted to created a new thread under General System > Kernel, boot, graphics and hardware since the controller works perfectly when plugged in and that I seem to have issues with other bluetooth devices…

1 Like