Problems after doing update today 08/02/23

Endeavouros Cassini 22 12 running on KDE 5.26.5 Grub boot loader

After doing a update the system would not reboot and no programs would load not even the terminal, I was forced to do a power off and now it will not start, I get the boot menu but which ever kernel I choose the will it will try to start but just fereezes, its like the grub is not finding the kernel. The system is dracut if it was using mkinitcpio I would have a go at rebuilding grub, but do not know what to try next.

Can anyone help.
TomX

You are not getting any error at all? Can you share a picture of where it is freezing?

I just see at boot time is

booting ‚ÄėEndeavour linux, with linux linux-lts
loading linux linux-lts
loading initial ramdisk

and that all I get on error message,

TomX

Same problem today when I booted my eos i3wm.
Had to brute force poweroff; the new start took some time and i’m verifing a strange behaviour.

That sounds like an issue with display drivers possibly.

The system is booting but you stop seeing the output once it reaches a certain point.

If you want to rebuild the initrams, the dracut equivalent of mkinitcpio -P is dracut-rebuild. I am not sure if that will help or not though.

Meanwhile, after a new rebbot seems stabe

Thanks Datto for pointing me in the right direction.
The cause was the nvidia drivers I was able to boot from a snapshot and remove all the nvidia drivers with sudo pacman -Rd nvidia-390xx-dkms nvidia-390xx-utils lib32-nvidia-390xx-utils nvidia-settings and installed all the updates and the system rebooted just fine. The only problem is that with out the nvidia drivers the system will freeze from time to time which force me to hard power off. I have tried following the info on the ArchWiki but I found it a bit confuesing so can anyone help with problem. My video card is Nvida Quadro K4000 GK106L.

TomX

keep in mind that these AUR builds are currently not maintained… on my latest testing I was even not able to build and install nvidia-390xx-settings … and see your post shows nvidia-settings what may cause issue using it with the 390 packages…

Have you tried the LTS kernel?

It is possible the the old 390 drivers are not compatible with the latest kernel right now.

1 Like

good point @dalto
i do just update my legacy system and io can see the 390xx from AUR doe not work with them both latest linux and the LTDS one from repo… using nvidia-390xx-dkms both kernels booting into unresponsive black screen with blinking cursor and keyboard is not functional to reach TTY …

i was able to boot by removing all 390xx packages and install xf86-video-nouveau instead.

I have install xf86-video-nouveau which looks like its sorted the problem out.

TomX

1 Like