Problem with update

Hi,i have problem with update, i tried 1 to 4 packages bud receive the same error.

sudo yay -Syu
 -> Avoid running yay as root/sudo.
:: Synchronising package databases...
 endeavouros is up to date
 core is up to date
 extra is up to date
 community is up to date
 multilib is up to date
:: Starting full system upgrade...
 there is nothing to do
:: Searching databases for updates...
:: Searching AUR for updates...
:: 2 Packages to upgrade.
2  aur/archlinux-appstream-data-pamac  1:20221014-1 -> 1:20221210-1
1  aur/snapd                           2.57.5-1     -> 2.58-1
==> Packages to exclude: (eg: "1 2 3", "1-3", "^4" or repo name)
==> 3
:: Checking for conflicts...
:: Checking for inner conflicts...
[Aur:2]  archlinux-appstream-data-pamac-1:20221210-1  snapd-2.58-1

:: (0/2) Downloaded PKGBUILD: snapd
:: (0/2) Downloaded PKGBUILD: archlinux-appstream-data-pamac
 -> error fetching snapd: fatal: could not create work tree dir 'snapd': Permission denied 
         context: exit status 128

error fetching archlinux-appstream-data-pamac: fatal: could not create work tree dir 'archlinux-appstream-data-pamac': Permission denied 
         context: exit status 128

1 Like

Hi @Omurtak
I have seen this before
Just press ENTER only without specifying a number.
By the way, never run sudo yay only yay

Please let me know how it goes.


wow thank you very much , now everything is fine.
:beers: :beers: :beers:

1 Like

Great… I am glad I could help.
Please consider marking the solution (that it is solved).

Please note this from terminal. This is a very important message.

Also. . . There were two packages to update, and you chose to exclude package 3. . . Why? There is no package 3.

hmmm :wink:

This should have been marked as solution, not the comment saying to mark the solution for future readers. :sweat_smile:

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.