Problem wIth PulseAudio startup

Sometimes pulseaudio does not start after booting and logging in, and an error icon appears on the Volume Control plugin. Xfce, LXQt, Mate DE are installed. In this case, pulseaudio cannot be restarted manually. In my own directory, the pulse directory in the config directory somehow mysteriously becomes the ownership of root. I have to take ownership of this and everything will work flawlessly after the next boot and login. This error can also occur when switching DE.
What can cause this?

lspci > log.txt && lsusb >> log.txt && journalctl -b -0 >> log.txt && cat log.txt | curl -F 'f:1=<-' ix.io

And tell what you may have tried already or what you have configured related to Pulseaudio

Here are the last three systemd journals.
http://ix.io/2myL
http://ix.io/2myO
http://ix.io/2myP
I have not configured anything with Pulseaudio. I noticed the error on a test disk that also runs EOS. I started Doublecmd with sudo. Then I noticed that Pulseaudio was not running. I tried to start it from the command line, but I got the error message that I do not have permission to write to the /home/myusername/.config/pulse directory. Then I looked at who owned the directory in question and saw that it was root and the root group. Then I took ownership of the pulse folder. After restarting and logging in, Pulseaudio started normally again. Then I experienced the same error on my daily use machine as well. Later, the error occurred after normal boot and login, and especially after switching between desktop environments.

It’s not good again now. http://ix.io/2mzA I forgot to write that it all started after installing LXQt.

Have you tried resetting pulse by removing or renaming the ~/.config/pulse folder? Prefer you rename it .bak so you have a backup. Log out and or reboot.

Edit: I would do this from the originally installed desktop.

Of course, this was one of the first things I tried. This could be some LXQt related bug. https://www.google.com/search?client=opera&biw=1880&bih=945&ei=KubBXvXYIpKyrgSWwZywDw&q=lxqt+pulseaudio++error&oq=lxqt+pulseaudio++error&gs_lcp=CgZwc3ktYWIQAzIFCCEQoAE6BAgAEEc6BAghEBU6BggAEBYQHjoHCCEQChCgAVDdOljeVGCPWmgAcAF4AIABbIgBpAaSAQM4LjGYAQCgAQGqAQdnd3Mtd2l6&sclient=psy-ab&ved=0ahUKEwj1lbzSorzpAhUSmYsKHZYgB_Y4ChDh1QMICw&uact=5

máj 18 01:28:49 antergos pulseaudio[651]: W: [pulseaudio] core-util.c: Failed to open configuration file '/home/zoli62/.config/pulse//daemon.conf': Engedély megtagadva

could be that:

I set KillUserProcesses to yes and the problem is fixed at last!

sudo nano /etc/systemd/logind.conf

and add this line:
KillUserProcesses=yes
save the file with [Ctrl+X] and reboot

? nice to see a running Antergos install

Yes, I read that too. I didn’t dare set this up because the error still occurs after normal boot and login, but I’ll try it on my test disk.

My system is just called Antergos because I switched to EOS last year exactly according to your instructions.

1 Like

I set it up as described here. Unfortunately, I have been able to reproduce the error once since then. The pulse directory mysteriously became the ownership of root.

remove the pulse config folders before reboot !

In my previous attempts, I had already deleted the pulse directory, but it was re-created. It’s worth a try anyway.

systemctl --user status pulseaudio.socket

also see this:
https://wiki.archlinux.org/index.php/PulseAudio/Troubleshooting#Permission_errors_bug

Thanks for the link. This permission error seems pretty old, but it’s more like what I’ve experienced. Although in my case the owner of the /home/myusename/.config/pulse directory changes.

The daemonize = yes option has been shown to be effective for now. Since then, after multiple boot and login, pulseaudio works properly.

There is an additional problem, but it is much less important. After logging out of the LXQt desktop environment and then logging in to Mate, if you log out with the logout button, there are no system (event) sounds, although they are enabled in the Volume Settings. A workaround is to log in to Xfce after logging out of LXQt. Then after logging out of Xfce, we log back into Mate. So you already have a sound when you press the logout button.

Unfortunately, the joy was early. The problem has come up again since then. I think this is definitely an LXQt-specific error. Although it is also interesting that Debian Sid LXQt does not have this Pulseaudio bug.

rolling release model at Archbased :wink:
i would try installing pulseaudio tools and apps:

sudo pacman -S paprefs pasystray pavucontrol-qt

and give the output of:
systemctl --user status pulseaudio.socket

I think Debian Sid is based on a rolling-release model.

Since then, the bug has also been reproduced on a machine running Manjaro, where the pulse directory has also become the ownership of root. The difference is that LXQt is not installed on this computer. Even on a third machine, I found that pulseaudio, which runs Linux Mint 19.3 Mate, was not running. On this machine, the pulse directory did not become the ownership of root, but even after deleting the pulse directory, pulseaudio could not be restarted. After booting and logging in, the sound worked normally again. The only mistake was that there was no sound after clicking on the logout button, but this has been the case for a long time. (Button and window sounds are enabled.)
In summary, this seems to be a bug with pulseaudio rather than LXQt.

In the meantime, I found this. https://easylinuxtipsproject.blogspot.com/p/first-mint-cinnamon.html#ID2.4

In certain cases a file or folder permissions problem may exist in your personal folder(s), even without you being aware of it. The ownership of certain (hidden) files or folders might namely have been changed to root. Which could create unexpected malfunctions.

Interestingly, the sudo chown -Rc $ USER: $ USER $ HOME command did not change the owner of the pulse directory.

LXQt still seems to have something to do with the error, because if I log in to Xfce, everything works normally.