Problem with Hard Drive management

Hello! I’m a one month old EOS user and so far my experience has been mostly great! There’s only one big problem I have, and since it can get a little annoying, I thought it would be a good idea to ask here.
For reference, I already tried a few things with lsblk to solve 1) but none of them worked.

So I can basically separate my problem in 3:

  1. my internal HDD doesn’t mount on startup AND requires my password. And believe me, it’s a little annoying to have to type my password after starting my computer just to get access to my HDD (especially when all my files are stored there including wallpapers). This is a problem I’ve always had and I’m still not sure how to fix it. (for this one, I tried following [Tutorial] How to Permanently Mount External/Internal Drives in Linux but it didn’t work. I can re-do it if someone confirms this is the way to go and helps me understand what didn’t work the first time)

The two following problems only appeared like a week ago after updating EOS.

  1. None of my disks, internal (the one that requires my password) nor external (the ones that don’t) are mounted when I start my computer . It’s actually super annoying because I have to go to my file explorer and click each hard drive to get it mounted.

  2. My “Downloads” folder is in my internal HDD (the one that I have to password-mount everytime) and even after I mount it, my browser isn’t able to write in it at all (it simply can’t write in this drive, but can in others). It’s actually even more annoying than 2) since it worked perfectly a week ago and I download a lot of things
    EDIT: even Spectacle can’t write in my internal HDD, so that’s a system-wide problem, not application-wide

Taking it as you are using KDE Plasma, have a look at the following link/thread:

Perhaps also the output of the following command could be useful if the above won’t work for you.
With the disk you wanted to be mounted at boot attached:

lsblk -fs

and also the content of your /etc/fstab:

cat /etc/fstab

Would be useful to see the exact line you had added to /etc/fstab.

1 Like


Everything was indeed unchecked on this window (probably after the last update, and I’m dumb for not thinking about it earlier). I might still have some writing rights problems though, so I’ll update this thread when I restart my computer next time to see what was fixed and what still doesn’t work.

Hello @anon8478 and welcome to the :enos: forum

Here’s how easy it is in Gnome desktop and use the interface in Gnome Disks in settings.

Sorry, but @pebcak’s reply did not show up in the thread when I replied. Strange :ghost:

Thanks for the help too HMS_Endeavour.

Sadly I’m not using Gnome, and I don’t think I have an interface like this with KDE Plasma.

What I did solved 2), but the two other problems remain:

  • when I start my computer and connect to my account, it immediately asks me for my password again to mount my internal HDD
  • when it is mounted, it is mounted as “read only”, so I can’t do anything with what’s inside

Now I can provide what @pebcak asked:

lsblk -fs

cat /etc/fstab

# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a device; this may
# be used with UUID= as a more robust way to name devices that works even if
# disks are added and removed. See fstab(5).
#
# <file system>             <mount point>  <type>  <options>  <dump>  <pass>
UUID=52D4-32C7                            /boot/efi      vfat    defaults,noatime 0 2
UUID=c133c6c3-ac26-404f-bb25-9d48b4e1c264 /              ext4    defaults,noatime 0 1
tmpfs                                     /tmp           tmpfs   defaults,noatime,mode=1777 0 0

Maybe I can try my HDD to fstab again since I don’t exactly remember what went wrong when I tried this the first time, what do you think?

Are you sharing those NTFS partitions with Windows?

If positive, one reason for them being mounted read-only is that Windows might have left a hiberfil.sys file on them if you use hibernation and/or fast start up.

If that is indeed the case, you would need to disable those functions in Windows.

Please have a look at the following articles for which mount options to use for an NTFS partititon for it to be “Linux compatible”:

https://wiki.archlinux.org/title/NTFS-3G
https://wiki.archlinux.org/title/Fstab

yes I am indeed using it with windows as well, I’ll check if anything needs to be done, didn’t know about this.

I updated my fstab :

# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a device; this may
# be used with UUID= as a more robust way to name devices that works even if
# disks are added and removed. See fstab(5).
#
# <file system>             <mount point>  <type>  <options>  <dump>  <pass>
UUID=52D4-32C7                            /boot/efi      vfat    defaults,noatime 0 2
UUID=c133c6c3-ac26-404f-bb25-9d48b4e1c264 /              ext4    defaults,noatime 0 1
tmpfs                                     /tmp           tmpfs   defaults,noatime,mode=1777 0 0
UUID=F0125487125454A6                     /mnt/HDD       ntfs-3g defaults 0 0

And I’ll update as soon as I try this config


EDIT: after restarting, it did change the mount point from /run/media/yves/HDD to /mnt/HDD, but I still can’t write in it.

First, boot into your Windows and disable Fast Startup and hibernation. Perform a proper shutdown.

Next, try the following line in /etc/fstab:

UUID=F0125487125454A6 /mnt/HDD  ntfs-3g defaults,uid=1000,gid=1000,dmask=022,fmask=133, 0 0
2 Likes

that worked, thanks a lot!

1 Like

That’s great! You are welcome!

Please consider checking the solution box under the post which gave the solution to the issue.
This makes forum software to regard it as such and other users with similar issue would find the solution more easily.

And also, welcome to the community @anon8478!

:enos_flag: :handshake:t5:

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.