Problem with GTA IV

So the game launch but i have low fps, graphics looks like with some potato mod and sounds are lagging. If i launch without lutris sound is ok but the graphics look worse also have even less fps.
My specs are i3-4130 8GB ram, GTX 750 1GB
If needed i can also attach screens of settings in lutris, just tell which one needed.
Also if im asking i have the problem with hearthstone after few minutes of playing(completly random i can even play around hour) its start to lagging hard. Heroes of the storm is lagging also but already from begging(works perfect on win)

Which exact version of GTA IV?
Is this Steam or Wine?

First of all make sure that you have all requirements installed

1 Like

Wine i think i have all things installed also Disco elysium and dragon age origins works nice.

What you need to do is to create and put those files inside your GTA IV directory (where GTAIV.exe is):


-reservedApp 0


dxgi.maxFrameLatency = 1
d3d9.maxFrameLatency = 1

Download xlivelessaddon
copy it’s files there also:


I advice to set those settings at

CustomSavePath = ""
CustomSettingsPath = ""
RemoveRegistryPathDependency = 1
SkipIntro = 0
SkipMenu = 0
DoNotPauseOnMinimize = 1
BorderlessWindowed = 1
SkipWebConnect = 1
VRAMFix = 1

; With SkipMenu = 1, you can hold SHIFT on startup to access main menu, if needed.

; Report issues in this topic:

As long as you do all that (most of which fixes it’s faults despite what OS you use) GTA IV should work great, better than windoze in fact.

P.S. You haven’t answered what GTA IV version you use, that could be important.


Very Helpfull!

1 Like

You’re welcome, GTA IV is probably my favorite game ever!

GTA IV complete edition now it does not launch XD is possible that i fucked up something XD? file commandline.txt was already created i just wrote additional
-reservedApp 0

Oh, that explains it.
Try downgrader, CE have too many problems and cut-out radio, i advice to downgrade to v1.0.7.0 or v1.0.4.0.

No idea since i don’t see what you did or not, but it’s likely :joy:
You can try to just cut out those files and try one by one.

Also can you post your inxi -Faz please

But i think problem is CE, because it can’t load mods like xliveless which fixes game problems.

Well it looks like this, i should download missing dll and put them into windows folder in wineprefix?

Oh…not exactly. dammit, i hate those windoze installers, pretty sure it’s net framework requirement that should be installed via winetricks

P.S. don’t screenshot inxi -Faz, copy here as text

Sorry stupid me u cant see all in screen, thats all i copied that also checked now, ends same as this what i have under

  Kernel: 5.19.10-arch1-1 arch: x86_64 bits: 64 compiler: gcc v: 12.2.0
    parameters: BOOT_IMAGE=/vmlinuz-linux
    root=UUID=140b929b-b5ef-468e-a6fc-dfefb6a8f1f5 rw rootflags=subvol=@
    loglevel=3 nowatchdog nvme_load=YES
  Desktop: KDE Plasma v: 5.25.5 tk: Qt v: 5.15.6 wm: kwin_x11 vt: 1 dm:
    1: LightDM v: 1.32.0 note: stopped 2: SDDM Distro: EndeavourOS
    base: Arch Linux
  Type: Desktop System: ASUS product: All Series v: N/A
    serial: <superuser required>
  Mobo: ASUSTeK model: H81M-PLUS v: Rev X.0x serial: <superuser required>
    UEFI: American Megatrends v: 0807 date: 05/15/2014
  Info: model: Intel Core i3-4130 bits: 64 type: MT MCP arch: Haswell
    gen: core 4 level: v3 built: 2013-15 process: Intel 22nm family: 6
    model-id: 0x3C (60) stepping: 3 microcode: 0x28
  Topology: cpus: 1x cores: 2 tpc: 2 threads: 4 smt: enabled cache:
    L1: 128 KiB desc: d-2x32 KiB; i-2x32 KiB L2: 512 KiB desc: 2x256 KiB
    L3: 3 MiB desc: 1x3 MiB
  Speed (MHz): avg: 1450 high: 3400 min/max: 800/3400 scaling:
    driver: intel_cpufreq governor: schedutil cores: 1: 800 2: 800 3: 3400
    4: 800 bogomips: 27208
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3
  Type: itlb_multihit status: KVM: VMX unsupported
  Type: l1tf mitigation: PTE Inversion
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable
  Type: meltdown mitigation: PTI
  Type: mmio_stale_data status: Unknown: No mitigations
  Type: retbleed status: Not affected
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
  Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
    STIBP: conditional, RSB filling, PBRSB-eIBRS: Not affected
  Type: srbds mitigation: Microcode
  Type: tsx_async_abort status: Not affected
  Device-1: NVIDIA GM107 [GeForce GTX 750] vendor: ASUSTeK driver: nvidia
    v: 515.65.01 alternate: nouveau,nvidia_drm non-free: 515.xx+ status: current
    (as of 2022-08) arch: Maxwell code: GMxxx process: TSMC 28nm
    built: 2014-19 pcie: gen: 1 speed: 2.5 GT/s lanes: 16 link-max: gen: 2
    speed: 5 GT/s bus-ID: 01:00.0 chip-ID: 10de:1381 class-ID: 0300
  Display: x11 server: X.Org v: 21.1.4 compositor: kwin_x11 driver: X:
    loaded: nvidia unloaded: modesetting alternate: fbdev,nouveau,nv,vesa
    gpu: nvidia display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1680x1050 s-dpi: 99 s-size: 431x272mm (16.97x10.71")
    s-diag: 510mm (20.07")
  Monitor-1: DVI-D-0 res: 1680x1050 hz: 60 dpi: 99
    size: 433x271mm (17.05x10.67") diag: 511mm (20.11") modes: N/A
  OpenGL: renderer: NVIDIA GeForce GTX 750/PCIe/SSE2 v: 4.6.0 NVIDIA
    515.65.01 direct render: Yes
  Device-1: Intel 8 Series/C220 Series High Definition Audio vendor: ASUSTeK
    driver: snd_hda_intel v: kernel bus-ID: 00:1b.0 chip-ID: 8086:8c20
    class-ID: 0403
  Device-2: NVIDIA GM107 High Definition Audio [GeForce 940MX]
    vendor: ASUSTeK driver: snd_hda_intel v: kernel pcie: gen: 2 speed: 5 GT/s
    lanes: 16 bus-ID: 01:00.1 chip-ID: 10de:0fbc class-ID: 0403
  Sound Server-1: ALSA v: k5.19.10-arch1-1 running: yes
  Sound Server-2: PulseAudio v: 16.1 running: no
  Sound Server-3: PipeWire v: 0.3.58 running: yes
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: ASUSTeK H81M-C driver: r8168 v: 8.050.03-NAPI modules: r8169 pcie:
    gen: 1 speed: 2.5 GT/s lanes: 1 port: d000 bus-ID: 03:00.0
    chip-ID: 10ec:8168 class-ID: 0200
  IF: enp3s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
  Local Storage: total: 585 GiB used: 338.58 GiB (57.9%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/sda maj-min: 8:0 vendor: Western Digital model: WDS500G2B0A
    size: 465.76 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
    type: SSD serial: <filter> rev: 90WD
  ID-2: /dev/sdb maj-min: 8:16 vendor: Samsung model: MZ7LN128HAHQ-000L2
    size: 119.24 GiB block-size: physical: 4096 B logical: 512 B
    speed: 6.0 Gb/s type: SSD serial: <filter> rev: 4L0Q scheme: MBR
  ID-1: / raw-size: 119.14 GiB size: 119.14 GiB (100.00%) used: 90.19 GiB
    (75.7%) fs: btrfs dev: /dev/sdb2 maj-min: 8:18
  ID-2: /boot raw-size: 100 MiB size: 98.4 MiB (98.42%) used: 98.4 MiB
    (100.0%) fs: vfat dev: /dev/sdb1 maj-min: 8:17
  ID-3: /home raw-size: 119.14 GiB size: 119.14 GiB (100.00%) used: 90.19
    GiB (75.7%) fs: btrfs dev: /dev/sdb2 maj-min: 8:18
  Alert: No swap data was found.
  System Temperatures: cpu: 40.0 C mobo: N/A
  Fan Speeds (RPM): N/A
  Processes: 248 Uptime: 3h 23m wakeups: 0 Memory: 7.7 GiB used: 3.02 GiB
  (39.2%) Init: systemd v: 251 default: graphical tool: systemctl
  Compilers: gcc: 12.2.0 Packages: 1521 pm: pacman pkgs: 1517 libs: 479
  tools: pamac,yay pm: flatpak pkgs: 4 Shell: Bash v: 5.1.16
  running-in: yakuake inxi: 3.3.21

Wow it looks so much better now XD

No problem, it’s still not full output though :rofl:
also put it in forum’s code tag, by using

code here
1 Like

meanwhile i see requirements is:


.NET Framework 4.7.2 (Should be installed on every Windows 10 machine) 


dotnet48 with winetricks to the wineprefix where you have GTA IV installed, if not sure how see this little example script called change variables to your paths and TRICKS to desirable dotnet48

Basically you should just run that in terminal, but put your path instead those $VARIABLES:


Then try running downgrader again, hopefully it will help

Indeed, but it’s just CPU, i need full output of

inxi -Faz

P.S First F is caps for a reason :wink:

Thx, i don’t see any obvious stoppers in your system / drivers, looks good to me.

1 Like

But be carefull, installing dotnet on a wineprefix often breaks other programms and games! Make a copy of the prefix!

1 Like

Yeah good point, well i assume that everyone have read my gaming guide and gone through reasoning of using separate portable wineprefixes instead of system one… :sweat_smile:


It works for @karnag again, he reinstalled the game again everything worked beside the audio.
I connected to him via RustDeskt and found out that he had a bunch of DLL overrides globaly set.
dsound dmusic etc. After removing this overrides everything worked again.

Thank you @keybreak your little guide helped a lot to get the game to run smoothly and correct!

Game Version: Grand Theft Auto IV: Complete Edition V1.00

1 Like

Yes it works just like he said thanks again

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.