Problem with CRT monitor and some games

Hello, I have a probably uncommon problem in this LCD world.

I’m using a CRT monitor to play some older games.
Almost all games, when changing their resolution through their settings, don’t change the desktop/monitor’s resolution with it. What I mean by that : My desktop res is 1280x1024. I launch CS1.6 and set it’s res to 640x480, the game changes IT’S res but not the monitor’s, resulting in a blurry mess :

Now I found a fix for all source games. Put -nofbo in the game’s launch options and voilà, fixed ! The game now changes it’s resolution and the desktop/monitor’s res with it, making them match.

You can see by the big cursor and the scan lines, that this is now perfect.

But now my question is, is there any way to force this for all games ?

A bit of help, but which I don’t really understand it all :

What is -nofbo ?

“-nofbo” causes the game to change your desktop resolution to match the games and blit directly to the back buffer. The normal rendering method is to have an FBO that is the size of the screen you want for the game, then we make a window the size of your desktop and do an upscaled blit from the FBO to the backbuffer.

I would love to fix Unreal Tournament 1999 for example.