Problem using starship terminal prompt

Hello,

I am having a issue getting https://starship.rs/ terminal prompt to work. My locale output is:

C
en_US.utf8
POSIX

image
The main issue is with the glyphs which are not showing up. I am using kde and konsole. I have installed noto-fonts-emoji. I have tried following these tipo: https://starship.rs/faq/#why-don-t-i-see-a-glyph-symbol-in-my-prompt.
I have tried the suggested glyphs only one shows:
image

Thanks,

frog

And you installed it from the community repos or from the website? It was updated a couple weeks ago.

https://archlinux.org/packages/community/x86_64/starship/

What font is set in konsole?

Works for me, been using starship for years:

Alacritty left, konsole right.

I have just reinstalled from the community repositories.

The font on konsole is Hack.

I have just changed the setting to match yours and still the same happens.

I have the following fonts installed:

 1 extra/noto-fonts-emoji 20200916-1 [installed]
 3 community/nodejs-emojione 4.5.0-3 [installed]
 7 community/unicode-emoji 13.1-1 [installed]

Perhaps one of them may help?

Also have:

11 chaotic-aur/noto-color-emoji-fontconfig 1.0.0-1 [installed]

But can’t remember why :smiley:

edit also my fira code is

archlinuxcn/nerd-fonts-fira-code 2.1.0-4 [installed]
3 Likes

Hello,

The combination of extra/noto-fonts-emoji and chaotic-aur/noto-color-emoji-fontconfig 1.0.0-1 fixed the issue.

Very Thankfull Frog

4 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.