Problem updating, cannot remove corrupt file halting system upgrade

electron25-25.3.0-1-x86_64.pkg.tar.zst is being reported by pacman to be corrupt. I tried removing it using “sudo rm”, at one point the command happened, but the file persisted, now using the same command, it tells me the file doesn’t exist, yet i can see it in there using Dolphin and pacman cannot proceed. I tried updating keyrings via "
sudo pacman -Sy endeavouros-keyring", but they are updated so no problem there. I read online to change attributes of that file, but like with the “rm” command, it cannot find it anymore, but it’s still there…


sudo pacman -Sy archlinux-keyring
sudo pacman -Syu

If it doesn’t work, please post the full output here.

I don’t understand how arch’s keyring was the solution here… but okay. I need a updating problems solutions cheatsheet somewhere. This happens every time i don’t update in months.

The vast the majority of the packages come from the Arch repos, not the EOS repo. The EOS repo only has a small number of packages that are either tools we create or things we package because we need them in the installer.

That is the issue. The archlinux-keyring dates faster than every few months. :laughing:

The package was most likely not corrupt. But it was signed by a newer key than the keys in the old archlinux-keyring package.

1 Like

this is not a command that should be use dto remove a package on archbased/arch and in general … you need to use package management to remove packages, same as installing them… If not you will break the package db

For updating your system you could consider using command


This updates keyrings first if needed. Then it updates the rest.

To see its options, use command

eos-update -h

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.