Problem to install and set fish shell

I installed the fish package from community but for some reason the omf command would not work, i tried the omf command to install theme but it did not work, i tried unistalling fish with yay -R and ran this command from github page instead but it’s giving me an error:

curl https://raw.githubusercontent.com/oh-my-fish/oh-my-fish/master/bin/install | fish
bash: fish: comando não encontrado
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
 26 19035   26  4994    0     0  80048      0 --:--:-- --:--:-- --:--:-- 80548
curl: (23) Failure writing output to destination
[ramon@ramon-m61pmes2p ~]$ 

If you don’t have fish installed you can’t run that command. It uses fish.

That being said, you probably shouldn’t be running random scripts from the internet. What are you trying to accomplish?

1 Like

Just install fish and set a theme to it, that’s all, the community package kinda worked and i had the default theme but the omf command would not work for nothing.
I always use the profile setting from konsole to set the shell
Edit: i realized i was doing wrong, i was trying the curl command for oh my fish without the fish package installed :man_facepalming:

Did you add exec fish to your .bashrc file?

Where do i find this file ?
I already managed to install fish, omf and set it my new shell using the profile setting from konsole.
I just have been trying to remove that welcome message that appears whenever i launch the terminal now.

If you’re asking that, I would probably discourage you from fish. It’s not the must beginner friendly thing and nearly ruined my install.

If you’re insistent on learning and implementing it, everything is in their documentation.

https://fishshell.com/docs/current/index.html#installation

I would suggest to use zsh with some plugins (all available in the repos) instead of fish. You get the same functionality but with a POSIX compliant shell.

1 Like

From his earlier post, he is setting it konsole

There is no reason to exec it .bashrc.

Even if he wasn’t, I would argue that is generally a bad idea. What if you need to run bash for some reason?

2 Likes

https://wiki.archlinux.org/title/Fish

According to the arch wiki bash --norc. That being said, I missed the part about the konsole setting, so I guess that is better.

It’s in the root of your home directory, but apparently you don’t need to actually do it that way. to answer the how to remove the greeting, enter set -U fish_greeting in the terminal.

After further re-reading and playing around with different commands I change my answer from just using exec fish to if [[ $(ps --no-header --pid=$PPID --format=comm) != "fish" && -z ${BASH_EXECUTION_STRING} ]] then exec fish fi Since it lets you just use the bash command to drop back into bash with your .bashrc settings intact. I like doing it this way because I can use any terminal emulator, and it will work instead of having to set up fish separately for each terminal if I decide to try another one.

may be @djwyman try say " Setting fish as interactive shell only " @ramon395 take look at archwiki on fish shell…

That’s what I was going off of. Until just now, I kinda overlooked the tip block that talks about the very issue @dalto was talking about. After reading through that tip box, I found that using the command in the .bashrc I posted above you can drop into bash when needed.

ok… i understand where i make mistake on understanding thread . :pray:

1 Like