Problem mit Tor-browser

Hallo,
Tor-Browser läßt sich nicht mehr starten.
Ist was mit dem Browser passiert oder hängt das Problem mit java4j zusammen ? :pensive:
Habe Atlantis mit Cinnamon installiert.

Guten Morgen!

Wenn Du den Browser vom Terminal aus startest, werden Fehlermeldungen geworfen? Vielleicht verraten diese Dir was.

Er läßt sich über pamac und über terminal einwandfrei installieren,
aber er läßt sich nicht öffnen.

Übrigens,
ich starte Torbrowser immer über das Startmenü, aber das wars,
er öffnet sich einfach nicht !! :thinking:

…und im Terminal sind keinerlei Fehlermeldungen !!! :anguished:

Das gar keine Fehlermeldungen kommen, ist blöd und verwirrend zugleich.
Ich mach das zwar nicht gern, aber versuch Tor mal mit sudo zu starten. Wenn er dann läuft, ist’s ein Rechteproblem, was die Suche zumindest eingrenzt.
–edit–
Ich seh gerade hier (https://tb-manual.torproject.org/de/troubleshooting/), das der Browser mit Options gestartet werden kann:

Oder um die Logs in einer Datei zu speichern (default: tor-browser.log):
./start-tor-browser.desktop --log [file]

Schau dann mal ins Logfile, irgendwo muss es ja was ersichtliches geben.

Hab ich noch nie gemacht, mit sudo - wie lautet da der Befehl im Terminal?

Einfach sudo tor - wobei tor der korrekte Name des Browsers ist (ich nutz Tor nicht, deswegen kann ich Dir das hier nur Beispielhaft beschreiben).
Sonst probiere mal den Eintrag von oben:

./start-tor-browser.desktop

Wenn dabei keine Fehlermeldung kommt a la “nicht gefunden”, sind wir schon auf dem richtigen Weg :slight_smile: Dann kannst Du den gleichen Aufruf mal mit ‘sudo’ versuchen:

sudo ./start-tor-browser.desktop

also die Befehle bzgl. sudo, da kommt der Hinweis - nicht gefunden.
Übrigens, ich hab was ausprobiert: ich habe über die Webseite
“Tor Project: Anonymity Online” den Torbrowser-Launcher heruntergeladen
und installiert u n d er funktioniert, allerdings habe ich im Startmenü keinen
Eintrag. Kann ich das so lassen ?

Wie hast du denn den Browser ursprünglich installiert? Und hast du schon eine De- und Neuinstallation versucht?

Wäre interessant zu wissen, wie der Starteintrag im Menü ausgesehen hat, als der nicht gestartet ist.
Den Startmenüeintrag oder eine andere Verknüpfung (z.B. auf dem Desktop) kannst du dir jederzeit selbst basteln.
Ich hatte den nie über das Paketmanagement installiert. Ich hab für solche Anwendungen (Tor Browser, TV Browser, PDF Sam) einen Ordner Anwendungen, in den ich solche Tools (Download von der HP) entpacke und dann Starter anlege. Dann werden die ohne Probleme aktualisiert und haben in allen Belangen auch wirklich nur Userrechte.

Ursprünglich habe ich den Browser in der Software von pamac-aur-git installiert - und hat funktioniert.
Dann habe ich POP OS ausprobiert, bin also raus aus EOS; später habe ich dann EOS neu installiert und dann eine Wiederherstellung gestartet - alles hat wieder funktioniert, nur nicht Torbrowser.
Im startmenü sieht alles aus wie wenn er funktioniert, da ist nichts zu sehen. Nur wenn ich das Symbol anklicke, passiert nichts.
Auch bei einer De- und Neuinstallation läuft alles ganz normal, also ohne Fehler.
Hat das vielleicht mit der Wiederherstellung zu tun ?

Gut möglich, dass es mit der Wiederherstellung zu tun hat. Aber wenn nach einer Neuinstallation jetzt wieder alles klappt, dann ist das Problem ja jetzt gelöst. Oder startet er auch jetzt noch immer nicht?

Dass das Symbol da ist, hat nichts zu bedeuten. Interessant ist, was hinter dem Symbol steckt (Programmaufruf, Berechtigungen usw). Um das zu sehen, musst du in den Bearbeitungsmodus des Startmenüs oder zumindest des Programmsymbols im selben.

Na ja, es gibt zwei mögliche Wege: 1. Installieren über pamac oder 2. installieren online von
webseite tor.
Die 2. Funktion funktioniert, die 1. nicht. Warum? Hat es mit Zugriffsrechte bzgl. Tor zu tun?,
in bezug auf die Wiederherstellung?

Wenn ich das Symbol anklicke, li.Maustaste, passiert gar nichts, re. Maustaste: zur Leiste, zum
Schreibtisch, zu den Favoriten hinzufügen.
Meinst du das?
Oder wie komme ich in den Bearbeitungsmodus des Startmenüs bzw. des Programmsymbols?

Um weiterzukommen, werde ich jetzt EOS neu installieren ohne Wiederherstellung.
Meine wichtigen Daten habe ich eh extern gespeichert, und alles andere eben noch
einmal von vorn. Danach werde ich Torbrowser ebenfalls neu installieren, dann sollte
es funktionieren !!! :innocent:
Ich glaube, das ganze Problem liegt in den Wiederherstellungsrechten…

Kannst du natürlich versuchen. Aber eines noch, du hast geschrieben

Ich finde im AUR kein Tor Browser Git Paket. Meinst du vielleicht dieses hier?

Das ist dann aber nicht der Browser selbst, sondern nur ein Hilfsprogramm, welches den Browser installiert. Würde ich aber eher nicht verwenden. Wenn du den Launcher willst, dann nimm die Version aus dem offiziellem (Community) Repo.

Oder, wenn du den Browser selbst willst:

https://aur.archlinux.org/packages/tor-browser/.

Die dritte Möglichkeit wäre, den Browser direkt vom Tor Project runterzuladen und (optional) selbst ins System einzubinden:

(Sorry, hab da gerade keine deutschsprachige Anleitung verfügbar.)

Hallo,
habe gestern wie ich geschrieben habe EOS nochmals installiert und dann als erstes Torbrowser
installiert, und ging wieder nicht!!! Hab dann EOS rausgeschmissen und Mint installiert, dort funktionierte der Torbrowser einwandfrei.
Heute Morgen habe ich dann EOS nochmals installiert, alles ohne Wiederherstellung, und siehe da,
der Torbrowser funktionierte wieder !! :slightly_smiling_face:
Möchte jetzt nur wissen, was da los war.
Kam da ein update von EOS zwischenzeitlich, denn eins war mir klar, an Wiederherstellungsrechten
o.ä. konnte es nicht liegen, wie ich erst vermutete ?
Ich glaube, es liegt bzw. lag an p a m a c .
Übrigens zur Klarheit, ich habe den Torbrowser von pamac installiert; mit pamac-aur-git meinte ich
die Version.

Hallo,
das ganze hat ja jetzt ein gutes und zufriedenes Ende gefunden - bis zur nächsten Überraschung ?

Ich wünsche euch vom Forum und allen, die noch dazugehören eine glückliche und gesunde Weihnacht
und ein erfolgreiches Neues Jahr.
Grüße aus Thailand