Problem booting Snapper snapshots with grub-btrfs [Fixed]

Moderation Note: This was split from Easy ways to restore snapper btrfs snapshots?

I tried installing all 3 and tested booting from a snapshot. However when I boot from a snapshot, I’m stuck at Reached Graphical Interface boot, it just keeps refreshing. I’m not able to go into a tty to try and sort out what’s happening.

I used the above page to install snapper manually along with grub-btrfs as I had not done it during installation with Calamares tool.

I’m having Endeavours Artemis with xfce and lightdm as my DM.

The issue is probably that you didn’t install the grub-btrfs-overlayfs hook in /etc/mkinitcpio.conf. This is required if you are using lightdm.

I think that snapper-support from the AUR was recently updated to do this for you.

After adding that, run sudo mkinitcpio -P.

Once that is done any future snapshots you take should be OK.

1 Like

Thanks a lot!

I had tried that first but missed adding the 2 files mentioned at step 1 here :

It works for me now, just tested the backups from boot. Was driving me crazy, I can go to sleep with peace of mind now.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.