Problem booting EOS as KVM guest in host with old kernel emulating UEFI

I have an appliance that provides a KVM-based VM service, but unfortunately, I have no way to update the kernel from the one supplied by the vendor, which is version 4.4, now seven years old.

I would like to run EndeavourOS as a guest UEFI machine, though I understand UEFI support in KVM may not have been fully mature in this earlier kernel.

I succeed in booting the install media, and (on the second) attempt, completed an installation of EndeavourOS.

I am using the default boot configuration in the boot loader (see screen shot), but have never been able to finish any boot cycle after installation. The sequence always hangs (see screen shot).

For comparison, I have similar problems with the Arch-based SystemRescue live system (see screen shots). I have tried SystemRescue versions 9.0.4 (the latest), 9.0.3, 9.0.2, 9.0.1, and 9.0.0, but was only able to boot the virtual machine I have described by reverting to version 8.0.7.

For further comparison, I succeeded in booting the most recent version of Linux Mint as a guest in the same environment. In this case, the guest kernel is version 5.15.

What might I try for successful booting of the EndeavourOS guest?

What are we talking about here exactly?

A Synology DiskStation.

Cool. Not sure what your problem is as you explained? I run virtualbox and vmware mostly but i have also used virt-manager. I’m not sure what vm software the Synology is using although i am familair with the product itself. UEFI should not be a problem but i can’t say for sure on this product as i don’t know the software it’s using. It could be another setting related to graphics. Right now virtual-box just updated and i always for years have used 3D but now that setting isn’t allowing it to fully boot so i just use VMSVGA. So i can only suggest that you try different settings and see what happens.

Thanks for the response.

You’re not sure what I am trying to communicate as the symptom, or what the underlying problem is?

As I have explained, the symptom is that the system will not boot.

They are using KVM, as I mentioned, through QEMU.

Based on the console output up to the point of hanging, do you think that a display issue is particularly likely?

I just installed virt-manager and is working to boot the latest ISO.


Edit: Using virtio & no 3D

Yes, I understand it is possible to run Endeavour OS in a UEFI VM with a Qemu/KVM stack.

I am seeking support resolving the particular problem I have reported, given my constraints on the environment.

Thanks for your help.

Sorry i can’t help as i don’t know how KVM works on a Synology Disk Station. :man_shrugging:

You can try installing lts kernel when installing…
Would be same as used on mint …

I understand. As I have explained, it is simply a Qemu/KVM stack running on an old kernel.

I see. The idea is that the newer kernel may be introducing an incompatibility with the hypervisor?

How do I use the LTS kernel? I had not noticed it as an option in the assisted install sequence. Would it be possible to install the LTS kernel on the installed system by booting to the installation media?

Using arch-chroot out of booting the iso installer will be possible.
Depends on uefi or legacy install and btrfs needs to get the mounting right… and once arch-chrooted into the system you can run:

pacman -Syu linux-lts linux-lts-headers

grub-mkconfig -o /boot/grub/grub.cfg

To add it to bootloader after this it should be choosable on boot menu

I successfully installed the LTS kernel, though doing so did not help boot.

However, I did succeed in booting by changing the video type from vmvga to vga. I am not sure why the installed system would not be able to finish booting despite the differences in emulated video hardware, or why it would hang without providing any diagnostic information.

this is normal for archbased to have such issues with the display mode …

Why? Isn’t it usually just a choice to include the necessary modules in the installation?

This is what I originally suggested it could have to do with the graphics setting. This is quite common on KVM Qemu. I told you to try changing some settings to see if that made a difference. I don’t know how the KVM works on this Synology.

I’m sorry I overlooked your suggestion earlier. It simply seemed to me not congruent with the symptoms or with my experience.

Ideally a fresh installation would boot in most environments, and problems with graphics would not prevent completion of the basic boot sequence, to a login console, even a text-based one.

I am now suggesting that EOS/Arch could adopt the same level of support and compatibility as other distributions, by a choice of inclusion of appropriate kernel modules, and other adaptations.

This is not my experience on any Linux distribution or VM . Sometimes this happens.

Arch is more like not doing everything automatically or starting any service anyone may need.

EndeavourOS supports VirtualBox virtual manager (qemu) and VMWare, where we implement possible modules for users… installer is automatically detecting and installing, and enables needed modules.

I understand, but a system being too crippled to boot carries no benefit.