Printing Support

Hello All:
Still working on my new install (Oct 2021) on EndeavourOS. Ran into a printer issue, I have an Epson XP-7100 All in One, Works on MacOS and Windows, however there is no real Linux support. That being said, I have had it working on Ubuntu and I believe CentOS in the past.

Tried to add it to my KDE Plasma DE through CUPS Web Interface. The latter says something like cannot copy PPD. The former just returns internal CUPS Server error. Is there something that can be done to get this installed, tried both Network and it is hooked directly to the computer via USB.

Hope someone can help!

I think you have to install this package from the AUR first.


Then when you try to install from the ppd point to the following:


This worked, thanks again! BTW: How is the weather there in CA? Still rather warm here in Kansas Ciry, MO USA :slightly_smiling_face:

Glad it worked for you i was taking a guess. It’s getting cold and we have had a lot of rain so it’s damp!

Thanks Again and really love the EOS so far, I PERSONALLY like it better than any other Linux distro I have used and been doing it professionally (RHEL mainly) for over 20 years now!

Stay Dry!

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.