Printing blocked by firewall

Firewall blocks incoming traffic by default. When the firewall is off can see the LPD/LPR option and can print. This is the only option that got to work, but it doesn’t appear if the firewall is on. What ports should be opened? Tried TCP/UDP 515, 631, and 9100 and working on trying all ports on this list: https://www.cups.org/doc/firewalls.html

1 Like

Have you checked the rules in the firewall?
Is 192.168.1.158 the address of the network printer? As most firewalls don’t care about green-side initiated connections, ie your pc, connecting to an external address, ie the printer, for it to receive the print job. Or are you going into another PC with Cups on it?
What do you get from nc -zv 192.168.1.158 515-9100 when the firewall on your PC is up?

1 Like

Gnome 40 destroyed extensions so switched to KDE (good choice, no dconf registry like settings, or every update breaking the extensions that make the desktop usable, but this is discussion for another topic.)

The printer shows up fine in KDE with the firewall on. Don’t know what the issue was with Gnome, but the issue doesn’t occur in KDE.

Thanks for help.

1 Like