Printers not working very well, and when they do they don't persist working on reboot

Hey, for some reason I can’t make my epson wf pro 7820 work with my computer? I’ve gotten it to work before, but I don’t remember how. It also stopped working after that. How do I fix this?

What driver do you have? It looks like the one for that printer on the aur is https://aur.archlinux.org/packages/epson-inkjet-printer-escpr2 before reinstalling or installing any printer drivers, make sure to uninstall any older ones. This is a basic guide for getting an epson printer running [https://github.com/meyertime/linux-all-the-things/blob/master/docs/arch-epson.md and here is a more advanced guide https://www.ordinatechnic.com/distribution-specific-guides/Arch/installing-an-epson-multifunction-printer-on-arch-linux-and-derivatives

I already have that driver, and the printer works when it does manage to connect.

Anybody know how to fix this problem?

…printer connection drops?
…or printer connection drops mid-use?
…intermittent connection? sometimes a connection?
–does the printer go into a sleep state? or hibernate? is there a way to disable that?
what does title mean? they don’t work well? and when you reboot they still don’t work well? but sometimes printer does work well?
remove driver, delete all remnants, reboot, and reinstall driver?
there could not possibly be anything disabling and re-enabling systemctl *.service, could there?
this couldn’t be a firewall /port issue (like a printer with a handful of users)?
things different with a usb cord? what have you ruled in? what have you ruled out?

that’s all I got on the software end off the top of my head.
On the hardware side I have had two dongles die…

this printer works on other computers and other distros
haven’t tried using a usb cord
they don’t work well, meaning they don’t work at all.
idk about disabling the services and reenabling.

ok, your title says sometimes they work but it doesn’t last so I was confused.
Your printer works everywhere but on Endeavour?
And it’s never worked on Endeavour?
If ^ that is true where did the driver come from? a targz then an .sh script? or did you pick the driver in the endeavour print settings?

I picked the driver in CUPS, and it does work, but temporarily, breaking sometime in the future. The driver is escpr-2 from the aur.

I don’t use cups so I don’t know about that stuff.
I would remove/tear out all the cups driver stuff.
then reboot.


then go into endeavour (these are budgie’s actually) print settings and hand-choose your driver.
if it’s not there do what I did in pic: pick one close.

if that doesn’t work I don’t know.
right now I’m in shock that my own print settings are grayed out with no option to unlock. this pisses me off so I have to start my own thread :face_with_raised_eyebrow:

I use cinnamon, and it doesn’t have a native print gui, just a gui for cups, so that isn’t an option.

bizarre. I used it for a while last year and I don’t remember being restricted to cups, but then again, I don’t even remember what I ate for dinner yesterday so there ya go…

system-config-printer is allegedly the command that brings up the cinnamon printer utility
edit: with or without sudo I don’t know

System-config-printer uses cups.

I can select the driver in cups, but it just doesn’t seem to work.

The message it says is Processing - Unable to locate printer "EPSON7F0F72.local".

Ok, I managed to reproduce a working printer, will reply later if it fails.


This is what it looks like.

It recognizes the escpr2 is its driver but I’m not sure it’s the right one.

it could very well mean a wifi problem. in the past I have also fixed these things by entering into settings the printer’s ip address manually…maybe that’s the reason there’s nothing under ‘Location:’?

I’m a usb cord guy with printers–I wish I knew more about wifi. Location is blank for a reason. I don’t know what the arch equivalent is for ipconfig but it would at least give you an address number…
…I see there may be nowhere to put that ip address though with that minimal interface…unless it belongs in the .conf file?
spitballin

It still works, so it must be the correct driver.

Hi, this is all i do for making a HP work in EOS.

sudo pacman -S --noconfirm cups cups-filters cups-pdf system-config-printer --needed

sudo pacman -S --noconfirm ghostscript gsfonts foomatic-db-engine foomatic-db foomatic-db-ppds foomatic-db-nonfree foomatic-db-nonfree-ppds gutenprint foomatic-db-gutenprint-ppds --needed

sudo pacman -S --noconfirm <your driver>

sudo systemctl enable --now cups.socket

sudo systemctl enable avahi-daemon;sudo systemctl start avahi-daemon

You can configure and administrate your printer in cups with
http://localhost:631/

Good luck