Printer not working

Hi all, back again ! So, a few distros later,i came back to Endeavour/ Deepin BUT:
i’m struggling to install my printer …
HP Deskjet 2630 - cups is not working so i installed hplip & nothing !
Does anyone has a clue ?
I must say that a printer is quite useful these days…
AND i had no trouble with former distros !
Many thanks & have a nice day/night
Fred.

Have you already looked at EnOS Wiki:

?

I normally use hp-setup for my hp printer. You can type hp-setup (ip address of printer) then it’ll pop up a box and you can follow instructions from there.

Make sure you have cups service enabled (reboot after)

1 Like

Thanks @pebcak , i’ll have a good look !
Cups troublesouting ?
I’ll check !
Cheers
F.

1 Like

Many thanks @OdiousImp but i wonder…
The link is physical so why should i use ip ?
Cant run hp-setup though…For the time beeing !
I have afternoon to find out !
Not that complicate ! Cups and/or Hplip running BUT they are not finding this {#^\¹¹printer !
Link ok, wifi ok…
Cheers
F.

1 Like

Oh if its physical link you can just run hp-setup and pick to connect via cable.

@OdiousImp …I try & choose ! Guess it cant be both ?
usb & wifi ?
F.

1 Like

@OdiousImp & @OdiousImp
A bit early but…Bon appetit !
(fr-FR/UTF8)
Fred.

1 Like

The current version of the HPLIP solution is version 3.20.11

If you check the list of printers supported on hplip the Deskjet 2630 seems to not be in !

https://developers.hp.com/hp-linux-imaging-and-printing/supported_devices/index

Bonjour @FLVAL …strange !
I un-installed then re-install hplip & no way !
Nothing appears…
I even get an icon saying i’m offline !
How come i have access to the forum ???
OK, another tea might do :smile:

Most HP printers will use hplip, some may use hpojAUR, while for multifunction laser printers hpuldAUR might be required. Some laser printers are also supported by foo2zjs-nightlyAUR. 

https://wiki.archlinux.org/index.php/CUPS/Printer-specific_problems#HP

@OdiousImp & @pebcak
So this xlfpy)ç"printer is recognized by …Cups !!!
Thanks for help, in fact i added what was mentioned by @pebcak, so it might very well work !
(Tea might have been of some help ! Ahahahah)
I’ll check AUR as said by @OdiousImp …Just in case !
Best & take good care
Fred.

2 Likes

The cups enable command has changed. It is no longer org.cups.cupsd.service. It is now sudo systemctl enable cups.service

1 Like

Morning’ & thanks @davidw …I think its done…
For, i did not impress anything yet, but this printer
is now beeing seen.
So i just think it works ==> sudo systemctl enable cups.service
I dont care that much beeing quite sure that i’ll have to
print stuff quite soon…For a noble or compulsary cause i guess !
Nice day
Fred.

3 Likes