Printer follies

I seem to having unusual difficulties getting a printer to work on EndeavourOS. the unusual part is that it is Brother printer (normally simple to configure) and that I successfully got it, and its scanner going on my Arch install. Can’t seem to get it though, and I can’t even get localhost:631 to access things - and I can’t remember exactly what I did on the Arch install to get things going.

It would be easy enough to bypass all the (apparent) mistakes I must have made, and re-install Endeavour - after all, that’s easy! But, I had the thought that If I knew where things were located in more depth/accuracy, I might get away with “borrowing” the configuration from the Arch setup by copying the relevant files/dirs as approriate. Any helpful thoughts on that course of action?

PS - I have scripts to help rebuild the environment, so the re-install isn’t particularly intimidating, but strangely enough for guy running Arch, I am actually kinda lazy… :grin:


Hello @freebird54
Which Brother printer is it? Did you remember when accessing localhost:631 to use root and password?

pacman -Q | grep cups
should see cups and cups-pdf at a minimum, if not install them

see if
systemctl status org.cups.cupsd.service is enabled and runningif not
systemctl enable org.cups.cupsd.service
systemctl start org.cups.cupsd.service OR reboot

Now it’s a matter of getting the proper driver, hopefully from AUR, and the brscanX driver installed.

Try accessing localhost:631 again.

And lastly, if this gets it going, jot this down in a linux notebook. Doing so has saved my south end of a north bound horse a lot.


1 Like

Nope - didn’t try root - might make a difference!

I’ll give that a try between periods (watching hockey…) as well as checking what’s installed. The printer is a DCP-7060D - and it is not in the AUR last I looked. The 8065 driver can work, but I managed the right driver last time (on Arch). Seem to remember following the Archwiki for the most part - but it doesn’t seem to help this time!


brscan4 is also in the AUR


1 Like

OK - I guess I’m not too good at finding things in the aur - I guess I should use yay instead of looking for myself…

Still no further ahead - configure printer can’t start up or connect. The cups services appear (to me) to be running:

freebird@aerie ~ $ sudo systemctl list-unit-files | grep cups
[sudo] password for freebird: 
org.cups.cupsd.path                                              enabled        
cups-browsed.service                                             enabled        
org.cups.cups-lpd@.service                                       static         
org.cups.cupsd.service                                           enabled        
org.cups.cups-lpd.socket                                         disabled       
org.cups.cupsd.socket                                            enabled        

I feel fairly sure I screwed something up earlier :grin: - oh, and I do have brscan4 ready and waiting for when I can use the printer.

Forgot to ask - HOW to get to localhost:631 with root? Something other than brave or firefox?

You should be able to put localhost:631 in the browser url window and access cups. It may require root as user and your password.

Once in you can manage printers, delete printers etc.



1 Like

If you are unable to access see what the output is of.

sudo grep “Listen” /etc/cups/cupsd.conf

sudo systemctl status cups

If necessary
sudo systemctl restart cups


Also check and see
netstat -tupln|grep 631

What browser are you using?

1 Like

Still unable to get into localhost:631 - and I’m pretty sure that’s how I got it going on Arch a few months back. I use Brave and sometimes Firefox, and get nowhere with either. Here’s the Brave feedback


Checking the connection
Checking the proxy and the firewall

The other things are mostly just returning to the prompt without any information - but apparently the cups.service is not found. Which seems odd given the list-unit-files posted above…

I am getting closer to dumping it and starting from scratch in a more known condition. I figure the problems started from not just following the Archwiki and trying to do it ‘the easy way’. Did I mention that sometimes lazy factors in?


It could be the chromium browser giving you a hard time not allowing access. :speak_no_evil:

Maybe - but it gets further in than Firefox! On the fox I get blocked from localhost:631 - on Brave I get that, but I can’t make any selections (like admin or printers) without getting blocked. Oh well - tha game is over now, so maybe I’ll just blow this thing up :grinning:


On Brave you get what? What does it show you?

Edit: Check if avahi is installed and daemon is running.

systemctl start avahi-daemon

systemctl enable avahi-daemon


Do you have a firewall on to prevent connections?

I’m on Windows right at this moment so I can’t check my own cups.conf, but I had to fight it to get to work this time.
Can you post yours?

On Brave I get into localhost:631 main screen, but trying to anything is blocked as shown earlier.

I haven’t worried about avahi, as I have a USB connection, and don’t really need to print from anywhere else - and if I do, samba will handle what I need.


Firewall settings are identical (imported) to those on my Arch install, and they don’t cause any problems there. Thanks for the thought though.


What does man page say when you put this in.
man chromium-browser

I could post the cups.conf, but it wouldn’t show anything useful now, as I did what I ‘threatened’ to do and blew this install up. It took less than an hour with all the installs and tweaking (and adding in conkys and such) so it wasn’t a big deal - except for not allowing the finding of what the heck was wrong. After the install, had no trouble getting both the printer and the scanner functions going - with the correct drivers too. Had to install a lib32 of some kind (not in front of me right now, on Arch), and brscan4 and the cupswrapper for my system from the AUR, and it fired right up (and I have cups access from localhost:631 working too in the process).

So - the problem is REsolved, if not solved, but I’ll mark it that way so people know not to worry about it :grin:



Yes you need the lib32 whatever file as i have a brother laser and it won’t install the drivers until you install that. It tells you as soon as you try to install it that it’s missing that dependency.

Yeah - I can’t really blame them for not going back to update drivers from long-ago models - would be quite a project to update them all to x86-64. I’m just happy they make drivers available for nearly everything in the first place - not all manufacturers do!

I’m still amazed at the price/value for these Brothers - peanuts for print/scan and copy!