Poweroff gets stuck with "A stop job is running for ..." messages

Dear all,

I hope someone can give me a tip.

Starting a few days ago, when I power off my machine it runs into a black console with all messages about stopped services, but then it gets stuck with the following three messages:

(1 of 3) A stop job is running for User Manager for UID 1000
(2 of 3) A stop job is running for Avahi mDNS/DNS-SD Stack
(3 of 3) A stop job is running for Update locate database

There’s one line and it cycles through the three messages above.

I have no option other than pressing the Power button to switch off, otherwise it’ll continue forever.

Any idea what might be wrong? Thanks in advance
Cheers, Manuel

Sometimes after selecting “shut down” I get a message that it “failed” to update local database but no stickup. The “(2 of 3)” worries me because already my laptop is very slow copying 1GB+ files from one external USB disk to another, even v3.0 disks. Sometimes it holds up for many minutes although file manager progress dialog says 100% copied.

I have had the same problem, although not every shutdown. However when it does happen I usually hit CTR+ALT+DELETE which causes the system to do a soft reboot. After that I hit the shut down again and it shuts down with no problem. Haven’t figured out what is causing the occasional hang ups.

One thing that can cause occasional stalls, is the sync command.

By default, the Linux kernel writes data to disk asynchronously.
Writes are buffered (cached) in memory, and written to the 
storage device at the optimal time. The sync command forces
an immediate write of all cached data to disk.

As part of a reboot or poweroff, linux runs a sync command to ensure all files in memory and on storage devices are synchronized. I believe this sync is run as root.

sudo sync   =  Sync all mounted file systems.

If one has multiple storage devices, and they are mounted, they get synced further exasperating the problem.

If you have manipulated several large files during your session, this sync can take some time. When a ARM OS image is initially copied to the target storage device, the install script does a sync command as root. When one is syncing an entire OS it can take 10 minutes or more.

My advice, anytime one sees “A stop job is running for …” just walk away and come back in 30 minutes or so. In my expewrience, 99% of the time the system is not “Hung” and it will complete eventually. Much better than a forced shut down.


for further info.

I had the same problem. Restarting -> stop job for user running!

It is not recommended to switch off using the power button.
There is a much better way to restart the system shown in the thread. You will find it in the solution at my first post.

I hope this helps.

Thanks, @limotux. I suppose you mean this. I do have the SysRq key on my keyboard, but pressing that key when I get the full-screen console with the stop job loop, it doesn’t seem to do anything. Or did I misunderstand your point?


1 Like

You are welcome @msoutopico
It is not just pressing the key.
You have do do a few things as shown in the thread to enable this feature (as per the tread I gave you link to or as per the link provided by @ricklinux ).
Then you press ALT and PrintScreen key simultaneously and then with ALT still pressed you press R, then E, then I… etc.
You can as well do it as @ricklinux posted.

Sorry for late reply.
If I may ask, are you using the default kernel? If so give the LTS kernel a try. It is recommended by experts here to use LTS (unless you have a very modern/recent hardware that does not work with LTS - if I were you I would try LTS and see).

I’ll install the LTS kernel and remove the latest one. Or would the zen kernel perhaps be even better?

In the meantime, if this happens again, I’m not sure I understand the trick. If I press Alt+PrtScr and then release PrtScr but keep Alt pressed, I would type REISUB. Is that what you mean?

Thanks for your patience and your replies.
Cheers, Manuel

1 Like

Exactly but after doing the stuff mentioned to enable the REISUB

Better keep and do not uninstall just in case something breaks you will be having this kernel as a backup. (though I didn’t know of any problems with LTS)

You are welcome. I am glad to help.
This is one -or actually the number one- beauty of EndeavourOS, the community and the exchanges support and experience.

Are you on BTRFS or EXT4? Snapshots?.. (just curious)
You know of course the problems that happened with Grub.
So, I would like to share with you a thread I created that helped me finish with the Grub issue for good. I hope it helps you to create a “hook” to be sure you will have no problems with Grub. Grub Hook to grub-install and grub-mkconfig?

To be honest and fair, it was @dalto, @pebcak and many others who helped me with it. I owe them a lot.

I just want to be sure you will enjoy our distro.

1 Like

I had missed that link, this is clear now. Thanks.

Thanks, limotux.

My / partition has ext4. I guess that was the default.

I didn’t have the grub problem in this machine, I think the problem was solved when I installed eOS in this machine.

I had missed the whole explanation in your linked thread, but ricklinux’s post made it clear. Thanks. I’ve enabled the sysrq key and I’ll report here whether the REISUB commands help next time that happens.

Thanks again.

Cheers, Manuel

Maybe my thread was not clear as I was the one not knowing, and asking to know.
@ricklinux pointed you to the write direction clear and simple.

As far as I know there is still an issue with Grub, The developers for some reason (it is a bit technical for me), made it necessary to reinstall/update Grub after certain system updates. Mainly the kernel I believe, maybe others. You have to do the Grub reinstall and update manually. If you did not do it you bight end up with an unbootable system.
Maybe you did not have this issue because you still did not update something that requires the Grub to be updated/reinstalled. And because you are on EXT4 then you are not having system sanpshots (BTRFS) that require doing the Grub things more frequently.

I just chose BTRFS for a few reasons:

  • I can snapshot the system and boot to an earlier snapshot in case something goes wrong.
  • I believe the BTRFS technology will be the default file system.
  • Some time ago I tried BTRFS on a HDD, boot time was much faster. But I did not notice big difference on SSD currently.
    This is just what I think, may be wright, maybe wrong. and I generally tend to adopt the latest technologies.

Please try read about this issue here. I hope @dalto can help and guide much better than me.

As I have personally among many others suffered this Grub issue, I ended up creating a “hook”, which is something that does the Grub install/update… etc automatically when needed. Here Grub Hook to grub-install and grub-mkconfig? is how I made my hook, you may reaad about the Grub issue and “hooks” here in the forum.

Please take this Grub issue seriously to be sure you would not end up with an unbootable system.

As I perhaps mentioned it happened with me for a few times and it was gone on its own. I do not know why it happened and why it gone. Maybe a kernel update solved it. I am on LTS by the way as the experts here recommend it. Hopefiully we will not have it again. (luckily now we have REISUB working anyway)

I had the grub issue in two other machines running eOS (from USB pendrives), I could fix it easily following the tips on the home page. No problem in this machine (with eOS installed in the hard disk). Cheers !

1 Like

Cheers. I hope you enjoy it here.