Power Profile Quick Settings Missing

So after playing around with masking power-profiles-daemon and trying TLP + auto-cpufreq I’ve determined that going the “old fashioned” route is just not cutting it on my machine.

I’ve uninstalled TLP and auto-cpufreq and re-enabled power-profiles-daemon and for the time being I am happy staying with this ‘default’ option (should have all along).

However, the ability to change power profiles from the quick settings is completely gone for me and I do not know how to bring it back. Any help would be appreciated.

Side Note:
I’m a bit frustrated with my battery life on EndeavourOS Gnome (not Endeavours fault I imagine), as an HP machine with the ‘same’ hardware as mine with the only difference being it has a 41Wh battery and I have a 37Whr battery, claims an 11hr battery life and my brand new machine barely gets past 4 hours on battery.

What’s the status of the daemon?

systemctl status power-profiles-daemon

If it is running, it is odd that you are missing the quick settings.

I have myself masked and re-enabled the daemon several times for the purpose of testing other options and after unmasking and restarting the system the quick settings have always come back.
Don’t remember though if a reboot was needed.
Reboot and check.

Also have a look at: powerprofilesctl --help for setting power profiles from a terminal.

Perhaps you could also have a look at powertop to see what is consuming power on your system:

https://wiki.archlinux.org/title/Powertop

Oh it’s running. Wouldn’t make that mistake, even have the profile settings in the regular settings menu.