Power management on Lenovo Ideapad 5 Pro 16ACH6

Hi! I have successfully installed EOS on Lenovo Ideapad 5 Pro 16ACH6, KDE, thanks!

To check power management I just ejected power supply plug, closed lid and went to sleep. In the morning I have got completely discharged laptop. All PM KDE settings are kept in default state.

Please, point me where to dig in to resolve the issue. My old laptop (Honor MagicBook 16 pro running Manjaro) takes about 7-10% during night. It would be great to get something similar.

This is just got probe from the laptop: https://linux-hardware.org/?probe=56a9b7ad32

sounds like youre just suspending and not hibernating. Im not positive hibernation is enabled on default as there are many systems that have serious issues with it. Manjaro may enable hibernation while EOS may not.

This arch wiki article should help with looking into setting up hibernation


if you recently installed EOS itll be using dracut which will require tweaking the instructions. If you have any questions setting it up i can try to help.

1 Like

On both laptop KDE Power Management setting are the same (that is “Suspend session” is checked, and “Sleep” is selected in combo box).

Yes, if you point me to Dracut power management related details, it would be great. EOS was installed yesterday (On LIne).

Edit: both laptop lack swap partition at all.

This is a recent guide on enabling hibernation in EOS with dracut, you will have to change the grub commands though as you likely are using systemd-boot

instead of grub commands you would simply add resume=UUID=<UUID of your swap partition> to /etc/kernel/cmdline (this is equivalent to GRUB_CMDLINE_LINUX_DEFAULT) then easiest way to regenerate the loader file is to reinstall the kernel with

sudo pacman -Syu linux linux-headers

I unfortunately cant test this as my system doesnt recover from hibernating. Follow this guide with the tweaks for systemd-boot i mentioned instead of grub and add a swap partition and youll be able to hibernate

You need swap for hibernation, its not optional unfortunately

I’m not sure I want a hibernation as far as old laptop hasn’t got swap partition also, but on suspend it is much more humble on power consuming.

The thing is, power consumption graph (I mean KDE Info Center) doesn’t change steep noticeably on lid closing.

At the moment I’m testing power consumption with blacklisted nouveau driver (I haven’t installed proprietary NVIDIA driver and, in fact, I don’t need equipped RTX 3050 at all, as far as don’t paly games). Is there a possibility to explicitly turn RTX off at all? BIOS seems to lack this option.

If you dont have drivers enabled for the 3050 it shouldnt even be on, if you dont have bios options thats your only bet.

1 Like

At my cases (I don’t need discrete GPU, that is NVIDIA RTX 3050) nouveau module blacklisting is the decision. More complete procedure to disable discrete GPU is described here: https://wiki.archlinux.org/title/Hybrid_graphics#Fully_power_down_discrete_GPU

It seems, nouveau driver isn’t aware of some PM-related details, probably proprietary NVIDIA driver is - have not tested as it isn’t my use case.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.