Post-installation Windows and NTFS issues

I was installing EoS on a single drive machine that had Win11 on it, with an almost-full UEFI partition on it. During the installation attempts Calamares has crashed twice and when it didn’t crash the bootloader failed to install regardless of whether or not the choice was GRUB or system-md boot, as well as resizing an NTFS partition with KDE’s partition manager present on the installation USB by around 50GB to make space for an EoS install.

Midway through that I’ve also attempted to clean up the original UEFI partition and boot options, removing dead and no longer used Solus and Manjaro bootloaders, which were installed some years prior to this.

Now, the installation problems have been resolved. After around 6-7 attempts I’m currently on EoS after making a clean 1GB boot-marked FAT32 drive and placing GRUB on it, but in the installation process I’ve incurred the following problems:

#1. Windows refusing to boot afterwards due to a BAD_SYSTEM_CONFIG_INFO-coded BSoD
Cloud and recovery partition reinstall options are also failing, however, I can access the console.
Microsoft support is, interestingly enough, directing me to the relevant distro’s forums instead of attempting to resolve the issue.

#2. The NTFS partition downsized by 50GB is refusing to mount
Windows’ chkdsk reports that it has issues, yet is unable to resolve them due to a “lack of access” on the admin terminal from the BSoD recovery menu.
It’s sister partition, which is also NTFS but wasn’t resized, does mount just fine and supposedly works just fine.

I’ll be happy to provide more information to replies, as I think I missed out on something.

1 Like

Update:

Still not sure what caused #1, looks like it did break at some point due to faulty management of the EFI partition, so the solution probably is just to reinstall from an .iso and call it a day.

#2 is solved, posting my solution for posterity’s sake.

Running sudo ntfsfix --clear-dirty /dev/sdXY resolved the issue, unsure if its a “good” solution but I have my data back.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.