Possible installation bug - Tracker not installed

Hi all,

Just installed Endeavour Gnome Galileo and all had been going well but I noticed that when I was searching for files from the Gnome overview nothing was being returned despite search working perfectly in Files. I checked settings for Search in Gnome Settings and the “Search Locations” entry was ghosted out and couldn’t be selected.

I typed “tracker status” into the Console, and it said, “tracker: command not found.”

I then installed tracker3-miners-3.6.2-1 from the AUR and rebooted and now the entire thing seems to be fixed. Files show up on search and the “Search Locations” option is now active and selectable.

Is it possible this app wasn’t installed as part of the default Gnome installation?

Thank you all.


You could install eos-package-list (if it is not installed by default) and run:

eos-packagelist GNOME-Desktop

to get a list of all the packages that are installed when you choose GNOME in EnOS’ installer.

EnOS’ tends to ship a minimal set of packages for the DEs available in the installer.

If you want the whole of GNOME’s “experience”, you could install the whole of gnome and also gnome-extra groups.

sudo pacman -Syu --needed gnome gnome-extra


https://archlinux.org/packages/extra/x86_64/tracker3-miners/ is on the official repositories.
no need to install/build from AUR … (this is not even in AUR)

Not needed in all cases it is a dependency for gnome-music gnome-photos both not installed by default.

But as @pebcak mentioned it is part of the gnome package group:


install that together with gnome-extras to get the full gnome set of apps installed…

1 Like

Much appreciated. I’m here to learn. Another lesson internalized. Thanks.

1 Like

Just discovered this today being boringly reading error logs.

There’s an entry every time you open the overview (where presumably the search feature triggeres the log):
nautilus[11142]: Could not establish a connection to Tracker: The name org.freedesktop.Tracker3.Miner.Files was not provided by any .service files

This is on a pretty much vanilla eOS install, and same as OP, while the extra tracker3 is installed, the miners are not. I am not sure this is for the best.

I understand that it still “works” and I understand the “minimal” approach (and love it to some extent), but is it worth not installing the miners, with the price to log errors?
Since a user chooses gnome on install, presumably one should give that user the full gnome experience, even if it is an Arch based distro. Perhaps I see this wrong?

This is showing on the Desktop interface? Or in the system journal only?

Welcome to EnOS’s community @Iiari!

I wish you a joyful ride on your Endeavour system!

Fwiw, regarding the tracker* stuff, I personally remove them in those systems that ships them with their GNOME flavor. I do my file searches in a terminal. The DE works fine regardless.

that’s what i do even on kde installs… even on modern multicpualotoframssdnvme systems search in filemanagers or DE implementations is very slow compared to cli tools…

The fileindexing can be useful for stuff like music or video collections to get some coverart and album info … but not everyone will need that.

1 Like

Exactly but I am one of those who don’t need that. I find Keep It Simple to be the best approach.

same would count for KDE installs.
there it is not easily possible to not let fileindexing run, as it would need to actively disable it.

The main issue is that almost all Distributions simple install everything possible from the Desktop group. And because of this users simply do not know why a feature they may used to have there by default is not working without the need to install a package to add this option.

On the other hand i would more like to disable fileindexing on kde too instead of enable a feature that can cause huge system rescource usage … what can be a problem on underpowered systems.

We could think about may adding it as optional group for these Desktops… but every bit extra is causing users getting confused.

Journal only, sorry if that wasn’t clear.

journal will always show that kind of error, not really errors in the meaning of real issues, there is nothing broken only that an option is not there and it is checking if the option is available.

tracker3-miners is the package that is needed to do fileindexing.

you can see:
Bildschirmfoto vom 2023-12-02 18-32-52

only gnome-music and gnome-photos are depending on that all others (like nautilus) have it optional

Just checked and i see that without the miner you can not search all stuff over the GNOME search… it finds pictures but not text files per example. But it will find applications and stuff.

I have no strong opinion but i do not see that it is a BUG.
Users want to use gnome-music and gnome-photos will get it in as dependency.
Only issue i can see is what i said already users may do not find out why it does not search for some mimetypes e.t.c and will may not what to do to get the option in.

Precisely. That was my situation. It’s worked everywhere else I’ve ever tried Gnome, but not here. While I consider myself at a “moderate” level in experience as a Linux desktop end-user, it took me a bit of searching to track this issue down and find and fix the problem, really only locating one direct reference to it online in another distro’s forums referencing what was some kind of packaging error (that’s why I thought it might be a bug). I think a less experienced user would be lost.

Perhaps it’s something that can be discretely addressed as a gain or loss of function option in the Endeavour Welcome app…

Thanks to all for the consideration.

Much appreciated, thank you. Other than this small hiccup, it’s been smooth sailing.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.