Poor Sound Quality

Poor Sound Quality in EndeavorOS.
When playing audio in endeavor, the sound quality is bad.
I am using a HP laptop and is dual booting with Windows 10. In Windows, there is no such problem.
The audio (in Linux) is heard like the speaker is in a container. The sound becomes distorted when someone (in the video) shouts.
I have tried to do various fixes like these listed in Manjaro forum. But this never worked for me.
If anyone can suggest any fixes it would be helpful.
(Forgive me for spelling or grammatical mistakes.)

Is this with all audio? I had an issue with VLC about a week ago where it was stuttering. But SMPlayer works fine for me.

Actually I was playing a video in YouTube via Firefox. Its stuttering issue but the audio quality is worse in Linux. In windows, I think it was using a software called HP audio ( I don’t the actual name) for sound optimization. I tried to do as said in this manjaro form. But it didn’t work.

That sort of statement doesn’t help much, we still don’t know what hardware we are talking about. You can use the eos log tool to post some useful infos about your system if you want help with your drivers…


Welcome to the forum btw :grin:

1 Like

OMG, how would you expect us to know what various fixes you tried? Better not use commands you don’t understand, maybe more harm than good on your system. For the sake of getting help, post exactly what you tried?

1 Like

Sorry for inconvenience. I am new to the forum. I will repeat this mistake again.
Link For System Information
Fixes I tried:
Created ~/.config/pulse/daemon.conf with:

default-sample-format = float32le
default-sample-rate = 48000
alternate-sample-rate = 44100
default-sample-channels = 2
default-channel-map = front-left,front-right
default-fragments = 2
default-fragment-size-msec = 125
resample-method = soxr-vhq
enable-lfe-remixing = no
high-priority = yes
nice-level = -11
realtime-scheduling = yes
realtime-priority = 9
rlimit-rtprio = 9
daemonize = no

Also Created /etc/asound.conf with:

pcm.!default {
type plug
slave.pcm hw

Later when I found that these configs worked I deleted these from my system.
( Thank you for your advice. I will never type random commands from the web until I know the source can be trusted.)

1 Like

Are you on pipe wire or pulse?

I have a set of Sony headphones that sound like slop hitting a tambourine in pulse, and would make you cry like you’ve never heard music before on pipe.

Ad2p is incredible.

I found this

  Device-1: AMD vendor: Hewlett-Packard driver: snd_hda_intel v: kernel
    bus-ID: 00:01.1 chip-ID: 1002:15b3
  Device-2: AMD Family 15h Audio vendor: Hewlett-Packard
    driver: snd_hda_intel v: kernel bus-ID: 00:09.2 chip-ID: 1022:157a
  Sound Server-1: ALSA v: k5.18.16-arch1-1 running: yes
  Sound Server-2: PulseAudio v: 16.1 running: no
  Sound Server-3: PipeWire v: 0.3.56 running: yes

I was wondering if worth trying a switch to pulse audio…

Edit: there are a couple of threads on the forum about this. If switching to pulse audio could be a solution. But read also the comments.

1 Like

No, even after moving to pulseaudio, the issue didn’t fix.
Instead I tried EasyEffects.
It had a wonderful article in its help section that really helped to improve the sound quality.
It does take some cpu (for me 12%). But it does its job.
Thank you everyone for their help. Without you all I would have never found the solution.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.