Polkit does not work

Ive installed polkit-gnome then i used (exec /usr/libexec/polkit-gnome-autentication-agent-1 &), afterwards i tried to open gparted from terminal but i get the message (Error executing command as another user: No authentication agent found.)


That path is not quite right. Did you get any error message when you ran it? The path should be like this:

/usr/lib/polkit-gnome/polkit-gnome-authentication-agent-1 &

You can add it to your config.py file so it starts automatically with Qtile, as described here: https://github.com/qtile/qtile/issues/1264

You need an authentication agent (v. https://wiki.archlinux.org/index.php/Polkit#Authentication_agents).

In Arch Linux ou can write an autostart.sh file, if you have polkit-gnome installed, like this:

#! /bin/bash
/usr/lib/polkit-gnome/polkit-gnome-authentication-agent-1 & # Graphical authentication agent

Don’t forget chmod +x autostart.sh.

Then put this at your config.py file:

def start_once(): 
     home = os.path.expanduser("~") 
     subprocess.call([home + "/.config/qtile/autostart.sh"])

You need to import os for this python code.

Then, when Qtile start, the authentication agent will start too (and all programs you call at your autostart.sh file, like a compositor, a wallpaper setter et cetera).


Thank you, that worked.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.