Plymouth on RPI4

I followed the Arch WIKI on this, but it uses the splash kernel parameter, but the kernel parameter in /etc/cmdline.txt is plymouth_enabled=0. I tried to change that to a 1 and this did not work. Also, it states to use sd-plymouth in the mkinitcpio.conf, but I get errors that this is not a valid option.

I don’t know much about this but try reading the documentation here (it might be a bit outdated)

The kernel we use is the linux-rpi kernel from the raspberry pi foundation and not the linux-aarch64 kernel.
Furthermore, Arch kernels and ARM kernel are a bit different. Again, I’m not an expert on this just my 2 cents.

I have it working, but the boot is so fast I only see the spinner for like 4 seconds. Just needed to add quiet splash before the plymouth line in the cmdline.txt file and add plymouth before udev in the mkinitcpio.conf file and disable sddm.service and enable sddm-plymouth.service.